Why can I not buy anything on the MakeUseOf Rewards page?

Ajarn Donald September 20, 2012

I can’t buy anything in the Rewards page. All the buttons say I must be logged in and I am logged in!? Please help me. Thank you very much.
Donald Patnaude

  1. Alex Perkins
    October 3, 2012 at 8:31 pm

    clear your cookies

  2. Amit Sinha
    September 26, 2012 at 9:50 am

    Actually you can't buy from the rewards page, you can only redeem your earned points for the available software

  3. Matt Smith
    September 20, 2012 at 11:32 pm

    Yes, clear your cookies and browser cache. If it still occurs, let us know. I'm the Rewards Editor and you can contact me via email: mattsmith@makeuseof.com

    • Donald Patnaude
      September 20, 2012 at 11:38 pm

      Thanks a million. It did work. Thanks everyone! I ate my cookies, cleared my browser cache and now I'm having a beer:)

  4. Lisa Santika Onggrid
    September 20, 2012 at 1:40 pm

    Try log-out then login again, if problem persists try clearing your browser cache or use different browser.

  5. GrrGrrr
    September 20, 2012 at 11:18 am

    Clear cache, cookies, close browser.

    Open browser, login back and buy

  6. Harish Jonnalagadda
    September 20, 2012 at 6:25 am

    I was also having the same issue. I tried Logging out, it wasn't working. So, I logged in from another browser, and I was able to check out the rewards.
    I think clearing the cookies in the browser might do the trick, though.

  7. Bruce Epper
    September 20, 2012 at 6:23 am

    Click the Logout link. It will log you out completely and bring you to the makeuseof homepage. Login again from here. You should now be able to access all pages and remain logged in, including the Answers section and the Rewards.

    • ahmed Fouad khalil
      September 20, 2012 at 11:39 am

      yes, this is a simle and proved solution

      • Karan Patwardhan
        September 20, 2012 at 1:44 pm

        worked for me too....also try clearing cookies of your browser...

Ads by Google