Why is my browser unable to go to https://addons.mozilla.org/?

mango wodzak September 7, 2012
Ads by Google

On attempting to get to https://addons.mozilla.org/, Firefox gives me the message:

You have asked Firefox to connect securely to addons.mozilla.org, but we can’t confirm that your connection is secure. Normally, when you try to connect securely, sites will present trusted identification to prove that you are going to the right place. However, this site’s identity can’t be verified.

What should I do?

If you usually connect to this site without problems, this error could mean that someone is trying to impersonate the site, and you shouldn’t continue.

Button that says: GET ME OUT OF HERE

Technical Details

addons.mozilla.org uses an invalid security certificate.
The certificate is only valid for www.google.com
(Error code: ssl_error_bad_cert_domain)

I get this message for numerous other sites too, but not all of them, like I can get to makeuseof no problems, and to me gmail account, I also get a similar message if I try to access the same site from chrome, and IE.

I believed it could be a rootkit problem, and ran a scan with malwarebytes, which although it detected 11 problems, I don’t think any of them were the issue at hand. I also download and ran the kaspersky tdsskiller program, which found zero threats. (actually the kaspersky.com website was another one I was unable to get to, so downloaded tdsskiller from another pc). Despite running malwarebytes and tdsskiller, I am still unable to get to those websites from this computer.

Any ideas?
Thanks in advance,

  1. Penny Cohen
    October 30, 2012 at 2:34 pm

    I get this message when I try to get into my settings.:
    This is the error code I get when I go into my account to try to change my password
    (Error code: ssl_error_bad_cert_domain)
    My yahoo account is sending out spam messages to all my contacts.
    I am running on a Mac
    Please help!!
    Thank you

  2. mango wodzak
    September 9, 2012 at 12:53 am

    OK.. I have succeeded in fixing the issue, although tobe honest I am not sure, what exactly fixed it. It didn't get fixed after a quick scan with MSE, and after a full scan, which showed up 3 infected files, none of which were likely to be active at the time, I then downloaded, installed and ran wise registry cleaner, it claimed to fix over 700 issues. I then rebooted, and voila, I am now able to successfully navigate to the mozilla page and others I was previously unable to access.

    I suppose I should stat a new question now as to why Windows Defender doesn't run for me, for that, I'm still getting the same error message as above.. does anyone know how I can uninstall and install it again?

    well, thanks to everyone that was kind enough to offer suggestions. really appreciate your help.

    • ha14
      September 9, 2012 at 11:00 am

      if you have microsoft security essentials then windows defender will not work since it is included inside.
      But if you do not have MSE and windows defender do not work perhaps to download a new copy of windows defender from microsoft.

      Open Msconfig, go to startup tab, Disable your Anti-virus > launch through Defender > Re-enable your Antivirus

      Turn Windows Defender on or off

      do you know what were the three infected files found by MSE

      • mango wodzak
        September 10, 2012 at 2:46 am

        Thank ha14, I wont worry about the windows defender then, as I have MSE installed.. I'll probably leave it there instead of immunet. At least for the time being.

        As for the 3 viruses that were found.. they were:


        I believe the first 2 were just lying dormant on the disk somewhere, and I'm pretty sure they had never been opened. The last one was in some temporary internet files folder..

        I am really not sure, but I suspect it was through running wise registry cleaner that the issue got sorted.

        thanks for your help and patience in solving this.
        kind regards,

  3. mango wodzak
    September 7, 2012 at 11:46 pm

    If the problem is a virus, wouldn't it effect all websites I go to? I mean it only seems to be certain websites I try to reach, the majority are OK.. I thought viruses were more malicious..

  4. 573d1210d64cc82ed1979188e3b9622a
    September 7, 2012 at 11:17 pm

    uninstall it and reinstall it there mustve been something funky with the download

    • mango wodzak
      September 8, 2012 at 2:12 am

      Uninstall firefox? how will that help when the problem is with all the browsers I have installed?

  5. ha14
    September 7, 2012 at 6:26 pm

    go to run and type cmd then hit enter then typ:
    ipconfig /flushdns hit enter

    if do not work try this on cmd
    netsh winsock reset catalog: (will reset winsock entries)
    netsh int ip reset reset.log: (will reset TCP/IP stack)

    • mango wodzak
      September 7, 2012 at 6:51 pm

      thanks ha14,
      I tried the first: ipconfig /flushdns

      and got the message:

      Windows IP Configuration
      Successfully flushed the DNS Resolver Cache.

      I tried a refresh on the mozilla page, and got the same message as before.

      So I tried your second suggestion, and after typing netsh winsock reset catalog, I got the message The requested operation requires elevation (Run as administrator)..

      So my next question is, how do I do that? I'm the sole user on the laptop (it's windows 7).

      • mango wodzak
        September 7, 2012 at 7:29 pm

        ok, I found out how to run cmd as administrator (instead of hitting just "enter", you hit ctrl-shift-enter).

        So I ran the 2 netsh commands, both ran OK. I had to reboot the computer after, and restarted firefox. Still no success. Exactly the same error message, and unable to navigate successfully to the mozilla addons page.

        any other suggestions?

        • ha14
          September 7, 2012 at 8:12 pm

          some other things to do
          Rename cert8.db (cert8.db.old) in the Profile Folder in case there is a problem with the files, If works then you can delete the renamed file or undo the changes to revert.

          Troubleshoot Firefox issues using Safe Mode, Reset all user preferences to Firefox defaults

          perhaps your antivirus is causing this, make the https://addons.mozilla.org/ in safe list.
          or ask your antivirus do not scan SSL.

          restart the router/modem

        • mango wodzak
          September 7, 2012 at 10:59 pm

          Hmm.. I understand that renaming a file in my firefox profile might fix something if the problem were purely firefox, but it isn't, it's the same for all browsers I've tried. Same goes for running in safe mode.

          My antivirus is immunet, I'm not sure that it can be the problem, as I believe it is mostly cloud based, and I just had a look at it and can't see how to add the site to a safe list, nor to not scan SSL.. any ideas? again, the problem is not unique to firefox..

          Recently I've restarted the modem/router on numerous occasions, after changes I've made.. I think there must be some other reason for this issue.. Many people seem to have solved it through correcting their computer time/date. but that all seems to be set correctly, so I'm really at a loss..

        • ha14
          September 8, 2012 at 8:30 am

          try to reset host file

          this fix it also

          go to run and type Diagnostics then click on it and open Windows Network Diagnostics. see what will tell you.

        • mango wodzak
          September 8, 2012 at 8:35 pm

          thanks Ha14,
          OK, I followed your steps.

          Firstly, and this may be significant, when I try to access the links you provided, I get the following message:

          404. That’s an error.
          The requested URL /kb/923737 was not found on this server. That’s all we know.

          Same goes for the 2nd link too.

          So I opened them from a 2nd laptop that is working fine.
          I followed the instructions in link one, resetting IE, closed all running programs then tried the reset. I got the message:

          Reset Internet Explorer Settings
          / Resetting User Customizations
          / Disabling browser add-ons
          x Applying default settings

          (where "/" is a tick, and "x" is a cross). Not sure why the applying default settings didn't work.

          I then looked at the host file, it was exactly as it should be for windows 7, with only # (comment?) lines.

          Then I went to run, and typed diagnostics.

          The window I got said:

          User Account Control
          Do you want the following program to make changes?
          Program name: Intel(R) PROset/Wireless Framework Launcher

          I selected "yes"

          It doesn't say "windows network diagnostics", but I continued..

          it says "Manual Diagnostics Tool" and a bunch of tests. All were selected, and I clicked "run tests". They all passed!

          I am still unable to get to the pages I'm trying to...

        • ha14
          September 8, 2012 at 8:52 pm

          install windows defender or microsoft security essentials (in this case uninstall immunet) and do a scan; see the result then you can reinstall immunet.

          see if you have NetFilter.exe, msxmlm.dll in system32 as infection

          perhaps also to Uninstall the Network adapter , reboot and reinstall a clean one.

        • mango wodzak
          September 8, 2012 at 9:39 pm

          hmm.. We may be getting somewhere here, although problem still exists.. I am unable to run windows defender, it tells me: "the specified service does not exist as an installed service (Error code: 0x80070424)"

          I tried to download it again, but, well, microsoft.com is another site I am unable to get to, so I used a 2nd laptop, and after downloading it, tried to install it, but got the message saying it was already installed. So, moved on to microsoft security essentials, which I downloaded, installed and ran a quick scan. It found one exe file (i think it was codai.exe), which it quarantined. I rebooted, and the problem persists still. I am now running a full scan with MSE.. (i fully uninstalled immunet first).

        • mango wodzak
          September 8, 2012 at 9:42 pm

          The quick scan of MSE found "VirTool:Win32/Obfuscator.VP" (I think it asked to submit the codai.exe to microsoft to examine).. the full scan is still running.

  6. Harshit Jain
    September 7, 2012 at 12:55 pm

    Try installing a new browser such as Opera or Avant. If sites open properly then there is problem with your previous browsers. Reinstall them. Otherwise do antivirus scan by downloading trial version of Norton Internet Security 2012.

    • mango wodzak
      September 7, 2012 at 6:07 pm

      I already have opera installed, and opera also is unable to navigate to that site. I get the message "the server's certificate did not match it's hostname. Accept?".If I approve, I am then taken to google.com

      I have run an antivirus checker, and (immunet, full scan) and the problem still persists.

  7. Erlis D.
    September 7, 2012 at 9:45 am

    Clean uninstall firefox, and reinstall it again! Don't forget to back-up your bookmarks, if you have added any!

    • mango wodzak
      September 7, 2012 at 6:07 pm

      Thanks for your suggestion, however, before I do that, I’m wondering why the same problem exists in both IE and chrome.. wouldn’t this suggest that it was not a browser specific problem?

      • Erlis D.
        September 8, 2012 at 10:40 pm

        Maybe it has to do with the antivirus or maybe other software you might have installed for boosting up your pc!
        Check if there is anything blocked by the antivirus, and also blocked by any of this programs!

        • mango wodzak
          September 8, 2012 at 11:26 pm

          I tried completely uninstalling my antivirus, and then seeing what happened. nothing. Apart from malwarebytes, there is nothing else running on my system, albeit a possible virus i'm unaware of.
          right now, as per ha14's instrunctions, i am running microsoft security essentials, a full run it's slow. i'll report back when it's done. i do suspect now it is a virus, because most of the websites i can't reach might be able to help me fix it in some way (can't reach, microsoft website, avg, kaspersky, mozilla.. - gmail, facebook and most others i can get to no problem..).

        • Erlis D.
          September 9, 2012 at 7:16 pm

          I see! If it is so important for you to fix this problem, than you should consider formatting your computer! Of course, if none of the ways you try, don't work!

  8. mango wodzak
    September 7, 2012 at 5:27 am

    And if I go to http instead of https, this doesn't fix the problem either, I still get the same error message.

    • mango wodzak
      September 7, 2012 at 6:01 pm

      Thanks for your suggestion, however, before I do that, I'm wondering why the same problem exists in both IE and chrome.. wouldn't this suggest that it was not a browser specific problem?

  9. mango wodzak
    September 7, 2012 at 5:17 am

    I also did a google search for similar problems, and it was suggested that the PC clock is probably set wrong. Well, just to make sure I went in to control panel, and it seems to be set perfectly, correct date, month, day, time and time zone, so I can't see how that could be the issue. I also tried clearing the browser cache, but that didn't help either.. anyone any other ideas?

Ads by Google