Why can’t I boot Ubuntu from a USB?

Rene Panta October 28, 2012

I tried to boot Ubuntu from USB on my Toshiba satellite a300-15i but nothing happened. The system finds my USB drive with Ubuntu on it, I’ve set it as first option to boot from, but when I hit enter, instead of booting, there is only black screen.
What to do?

  1. fallen heart
    March 16, 2013 at 4:23 pm

    u need two things to boot your ubuntu from usb 1st bootable usb with ubuntu on it 2nd usb usb bootable computer. before staring pc insert pendrive in ur usb slot and enter into boot menu clicking (f10 or del genrally ) choose usb from list. if your pc does not boots then there is some problem in your pc or bootable pendrive.

  2. Kannon Y
    November 1, 2012 at 1:19 am

    I get blackscreen from bootable USB drives all the time. And not just Linux disks, but also Windows bootable disks. Most of the time, it's something that I did, but fairly often it's either a bad download/not properly configured/bad copy to USB.

    Oftentimes these problems just mean that something went wrong during the burning or downloading process, although sometimes the problem persists even after getting a good copy or burning to disk using the proper settings.

    Far and away, the best results I've ever gotten were using the LiLi live USB burning software. Justin Pot wrote a fascinating break down of how the software works.

    One of the best features about LiLi is that it offers two great features: first, the option to download the ISO and, second, the ability to run the disk in a virtualized mode, directly from within your primary operating system. The second feature is highly useful because it basically tests to see if anything is wrong with your copy of Ubuntu (or whatever you've downloaded). Just remember to check both the boxes for virtualization in option #4.

  3. Brian Mok
    October 30, 2012 at 10:33 pm

    Have you tried loading USB from BIOS?

  4. josemon maliakal
    October 30, 2012 at 3:26 pm

    try unetbootin

  5. Patrick Jackson
    October 29, 2012 at 10:25 am

    Try reinstalling Ubuntu again.

  6. Erlis D.
    October 28, 2012 at 9:30 pm

    Format your usb in FAT32 format, and follow this steps:
    Check the section Creating a bootable Ubuntu USB flash drive > From Windows

  7. Mohanad Salah
    October 28, 2012 at 8:02 pm

    try reinstalling ubuntu using (unetbootin) or (universal usb installer)

  8. ha14
    October 28, 2012 at 7:17 pm

    Booting the computer from USB: with some motherboards you have to select 'hard disk/USB-HDD0' to choose the USB flash disk.
    The error "Can not mount /dev/loop1 on /cow" is because usb-creator.exe is not creating a valid casper-rw file holding ext2/ext3 filesystem. Fix: 1) Use Unetbootin or 2) After running usb-creator.exe, recreate casper-rw using cygwin tools or http://www.pendrivelinux.com/casper-rw-creator-make-a-persistent-file-from-windows/.

    1.Format the USB Drive to FAT32 (you can try NTFS also)
    2.Run Universal USB Installer as "Administrator"
    problem can be where the boot MBR would not be written/created as a normal user.

    Common USB BIOS boot options
    Older BIOS Boot Options:
    1.USB-HDD " Preferred boot method"
    2.USB-ZIP "May or may not work"
    3.USB-FDD "Unsupported"

  9. Alex Perkins
    October 28, 2012 at 3:29 pm

    Try creating a bootable stick using rufus, using the Ubuntu iso.

  10. prateek pandey
    October 28, 2012 at 11:26 am

    try to boot with an updated version if it does't work , use the latest version of wubi
    along with iso file of the ubuntu put then on the same folder and run wubi follow the simple instuctions and it will install ubuntu as a normal windows program .When your computer boot you can select which OS to load . Ask me if it doesn't works !!

  11. Lisa Santika Onggrid
    October 28, 2012 at 11:04 am

    Try again. My Mint refused to boot the first time, but it went smoothly the second time onwards. What app did you use to create the bootable USB? I used UnetBootin and it was hassle-free.

    If it still wouldn't load, try booting that USB from another machine.

  12. Nikhil Chandak
    October 28, 2012 at 8:30 am

    http://www.ubuntu.com/ ask ur problem here

  13. Milos Dedic
    October 28, 2012 at 8:16 am

    USB stick Must be formated in fat32 file system. If dosen't work from first attempt, tray few more times... I have a same problem, it always been problem in file system in my case with stick... ubuntu and mint too...

  14. Shankar C
    October 28, 2012 at 7:23 am

    use unet bootin

  15. Adrian Rea
    October 28, 2012 at 4:12 am

    Have you been able to boot on other computers? did you use Pendrivelinux or the Ubuntu diskCreator? in the bios is it set to use extended usb2 features?

  16. Anonymous
    October 28, 2012 at 4:05 am

    Was Ubuntu installed on the USB device or was a LiveCD dropped onto it? If the former, it is likely that the proper hardware drivers are not configured to load. Have you used the USB stick on another device successfully? Are you sure it has not been corrupted in some manner?

Ads by Google