Why can I not boot an iBoot and Multibeast installed OSX?

Arthur Leung November 28, 2010

I followed precisely the steps to install OSX on my PC, but found the following error on reboot:

Loading Operating System…
boot0: error
My configuration is-
Gigabute GA P55M-UD2
iCore 5-750
WD 1 TB SATA Harddisk
LG BD-ROM/DVD Rewriter.

  1. James Bruce
    December 8, 2010 at 3:05 pm

    Hmm, the only other thing I can think of is this solution, found on insanely mac forum, about setting your main osx partition to active - seems to be the other common cause for boot0 errors. Anyway, here you go, see if this makes a difference:

    Make the partition Primary
    Make the partition ID=AF (signifies an HFS partition)
    Make the partition Active
    There is a built-in Unix utility in MacOSX that can be used to set your partition "Active". It is called Fdisk

    Setting Your Partition "Active" Using Fdisk

    Words in bold below are things you must type (followed by Enter).

    1. Boot your Mac OS X install dvd
    2. Once the installer is running, go to the Utilities menu and open Terminal

    3. Determine which disk your MacOSX partition is on

    Type diskutil list

    Verify which disk number holds your partition (disk0, disk1, etc.)

    4. Start using Fdisk

    Assuming the MacOSX disk is the first disk ("disk0"), then
    type fdisk -e /dev/rdisk0 <== use "rdisk" with your disk number here !!

    Ignore the error "fdisk: could not open MBR file ..."

    5. Determine which partition for MacOSX needs to be set "Active"

    Type p

    Verify which partition is for MacOSX (1, 2, 3, etc.)

    6. Set the partition "Active"

    Assuming it is partition 1, then
    type f 1 <== use your partition number here !!

    7. Save and exit

    Type write

    Type y (yes you are sure)

    Type exit (to quit)

    8. Remove the install DVD and reboot

    • Arthur Leung
      December 22, 2010 at 3:13 pm

      Thank you James. I bought a 500GB harddisk and follow Tony's guide again and this time it works. I can boot from the HDD.

      • James Bruce
        December 27, 2010 at 8:58 pm

        Good to hear it!

        I just followed the guide myself last weekend for funsies and now have another quad core mac that my wife can use!

        (250gb drive, Nvidia 9600GT, EP45-UD3R Giagabyte motherboard which is very compatible, using custom DSDT from Tony and ALC889a kext and rollback)

        I must say Tony has made the whole process incredibly easy when evertyhing fits together right!

  2. James Bruce
    December 1, 2010 at 8:22 am

    Did you follow a tutorial or guide *specific* to your motherboard? It would be helpful if you could send a link to that. From the thread I've linked below, it looks like there are some specifics for that board in particular, with a i5 chip. It is not simply a case of pop in the latest iboot - you need to do a little prepwork on a real OSx machine first.


    You need to be a bit more specific with what you have done so far, what guide you are following, and far you got. When you say you got that error after reboot, I assume you mean you havent actually managed to boot into OSx at all yet? Judging on just that error message, it sounds like your hard drive settings in your BIOS are wrong - check the SATA is set to AHCI mode and not anything else, then check the other BIOS settings detailed in whatever guide you are following.

    I must admit I havent tried iBoot, but I always had luck with the Kalyway release, perhaps try that instead?

    Failing all that, just type your motherboard model into google along with hackintosh guide, and start again from step zero using a different tutorial.

    Getting a hackintosh to work is really a form of black magic. Good luck, and let us know how you get on, with some more details if you still can't get around that error.

    • Arthur Leung
      December 3, 2010 at 4:39 pm

      Thanks for your response. I followed closely Tony's guide in the installation. That is, the DSDT file, the retail DVD, the BIOS settings and Multibeast settings etc. but when I finish installation and reboot my Hachintosh PC without the iBoot CD, the installed OSX cannot boot from the HDD. It seems that I am not getting the bootloader right and the error message on screen is "Boot0 error". When I boot with the iBoot CD, I can boot into the HDD with OSX installed. Did I do anything wrong? Nonetheless, except the booting bit, the installed OSX runs perfectly. I can use the applications, have the sound driver working and the USB ports functining normally. I onced tried a Kalyway 10.5.2 installation and I can have the PC running with the OSX but with the sound driver and video driver not working. Anyway, any further advice will be much appreciated.

      • James Bruce
        December 6, 2010 at 8:37 pm

        Sorry for the late response, seems I'm not getting updates on replies for some reason...

        This may be a long shot, but try reducing the size of your hard disk partition to less than 1TB, even 950gb should do the trick. Try that and post back, though I realise this will mean reinstalling the whole thing again, which is a bit of an ass...

        • Arthur Leung
          December 7, 2010 at 6:39 am

          I have tried partitioning the HDD into two 500 GB partition but I still couldn't boot my installed OSX without the iBoot CD. Is there anything wrong?

Ads by Google