Why can I not use Backup and Restore in Windows Vista Home Premium?

Derald Hausmann February 21, 2011

I tried to open backup and restore in my Windows Vista Home Premium laptop and got this: ‘error-0x80040154 class not registered’.

I can click on both the backup tab and restore tab, but they are unresponsive. Also noticed restore points are deleted after only a few hours.

Don’t know if this is related, but I can’t copy and paste either. Mouse or keyboard, neither work. I tried Microsoft support but couldn’t get a straight answer.

Anyone got an answer?
Thanks, Derald H in MN

  1. Tina
    February 28, 2011 at 3:44 am


    were you able to fix Backup & Restore with the advice provided above? Please let us know! If the problem persists, I can add it to a list of toughest questions to be published this Tuesday.

  2. Anonymous
    February 22, 2011 at 9:29 am

    conflict between Vista and anti-virus software

    try to stop the the automatic updates service and after it stopped go to c:windows and delete the folder called softwaredistribution and then start the service and try to update again.

    February 21, 2011 at 9:42 pm

    Hello, when this error shows is because your system is damaged and it is missing system files. It can also have corrupt system components. The main cause for corruption and missing files are malware infections. Have you scanned your computer lately? I would scan the computer thoroughly with the following software:

    Make sure that you run full scans with the software from the links provided. If the softwares find anything, make sure to delete or quarantine the files. Once this is finished make sure that you update your system. Hope it helps.

  4. Mike
    February 21, 2011 at 7:48 pm

    Error 0x80040154 seems to a critical system problem and it can very well be related to all your other problems along Backup & Restore too.

    Try SFC to fix the corrupt/missing files:
    1. click Start > Run (Windowskey + R)
    2. type sfc /scannow
    3. hit enter

    You can also try Microsoft Fixit (Windows Live/Xbox/Hotmail/Messenger Login required)

    Or reinstall the latest Service Pack (should be your last option).