Why does audio stop working on my Win8 Asus laptop with “being used by another device” message?

Anonymous July 30, 2014
Ads by Google

Asus laptop running Win8 (NOT 8.1). Sometimes audio goes out. When I test my speakers it says “Being used by another device. Turn the other device off.” I can’t find the other device to turn it off. I’ve updated my drivers. It runs both the white speaker icon on the taskbar and an orange Realtek audio manager which has an orange speaker icon on the taskbar. I’ve tried turning off various services that say audio in the task manager, but the only way to get my audio back and the “in use by another device” message not to pop up is to restart or reboot.

I can’t find what’s causing it to go off. Sometimes my MagicJack works with the USB headset, but when I manually switch back to laptop speakers and test, I get no audio and the “use by another device” message. I thought MagicJack was the culprit, but when I safely remove the USB device I still can’t get my audio back. Sometimes even if I haven’t plugged in MagicJack this session, my Thunderbird mail sounder will go off, and then I lose audio. Sometimes my Comodo browser works until I go to page 2 of a website and then flash audio quits working.

I’ve updated my drivers, and Comodo, Thunderbird, and MagicJack are all up to date. Restarting works, so it has to be a process or service, don’t you think?

  1. Curtis James McConnell
    July 31, 2014 at 2:17 pm

    Jeff F -- I've tried Ending Task but not Restarting. Will try that next time it happens and report back.

  2. Jeff F
    July 31, 2014 at 6:01 am

    Does restarting the Windows Audio Service resolve the device in use error?

    • Curtis James McConnell
      July 31, 2014 at 2:25 pm

      Hovsep A --As with all Microsoft "solutions," this link wasn't helpful. It just goes to the troubleshooter. When I ran Troubleshooter before, I got "Couldn't find the problem, look online." Which is how I got to MakeUseOf. I found an earlier, similar problem, but the solution offered there was to look at the logs, The logs were empty. This earlier solution (2012) also suggested running eventmgr.msc. I tried, no such program found.

    • Hovsep A
      July 31, 2014 at 7:46 pm

      if you clean boot windows and test gain to see if the problem get solved