Why aren’t apps working right on my Galaxy S Plus?

player game October 18, 2012
Whatsapp Pinterest

I have a Samsung Galaxy S Plus. It suddenly stopped working with applications I downloaded from Google Play. I formated my mobile and downloaded them again, but the problem persists. They download without problem but I can’t use them. I mostly try to use messengers like WhatsApp, Kik Messenger and MeetMe. None of them can send messages like they should. I tried an antivirus but when I tried to update it, it says I have no connection.

  1. Siddhant Chaurasia
    October 22, 2012 at 11:14 am

    try updating your firmware. if still not possible download this app called MagicCode

  2. Kannon Y
    October 21, 2012 at 8:38 pm

    A lot of apps, particularly messenger apps, require a stable internet (like 3G or 4G or whatever) connection in order to work properly. I'm sure you already knew that, but it needs to be said at the very beginning of any answer.

    If you have a stable data connection, then the next most important thing to have is the correct authorizations from Google. Last I read, Google uses the Google Talk program for a variety of authentication purposes, including Google Market (Google Play). They may be phasing this out in favor of another program, but as of yesterday, I used Talk to authenticate my phone with Google's Play service.

    Anyway, sometimes data can become corrupted/outdated/etc in these services and you won't be able to authenticate your phone with Google's various services. You can fix this by wiping the application cache on each major service:

    To properly wipe their caches requires that you go to settings -> applications -> manage applications -> go to both play and google framework services. Then you can wipe their respective caches.



  3. susendeep dutta
    October 18, 2012 at 3:51 pm

    This means that while performing factory reset operation,there comes an option of Automatic restore.Try unticking it and perform Factory reset once again.Also,make sure that all the network setting from your carrier is accurate and verify with them whether they are facing any problem from their end or not.

  4. Boni Oloff
    October 18, 2012 at 12:08 pm

    Try to do a full restore. It makes the phone factory default again.
    May it will solve your problem.

  5. Harshit Jain
    October 18, 2012 at 10:18 am

    If your phone is under warranty, please go to the service center and ask them to reinstall the firmware. Don't forget to backup your data.

  6. ha14
    October 18, 2012 at 9:33 am

    did you tried to update the firmware?

  7. Kyem Ghosh
    October 18, 2012 at 3:07 am

    I'll ask you to clear your cache again even though you have formatted your phone. Next I'll suggest you to clean your phone with apps like CacheMate or titanium (pro version recommended). These apps are like ccleaner. Get them and see what happens. If again it does't work, I guess its the problem of the android os. Go to a service center ask them to reinstall the os.

Ads by Google