Why did my Android phone freeze on the boot screen?

Farhan K December 20, 2013
Ads by Google

I have a Qmobile Noir A10 Lite (Not Rooted) and it got stuck 3 moths ago when I was checking my Facebook. Then I waited 20 mins and it was still the same. Tried pressing every key and powering off but nothing happened. Then I took out the battery for a minute and then powered it on again but it got stuck on the boot screen. I observed the phone for half hour but it was still stuck. I tried many things but it didn’t work out so I took it to customer support and they replaced me my phone telling it was a hardware fault and noting else but I want to know the reason and how to prevent this problem if it occurs again on the same model.

  1. Dalsan M
    December 22, 2013 at 7:24 pm

    If you received a mount error, then I don't think there would have been much that would fix the issue. Reflashing the stock ROM through Odin may or may not have fixed the issue as it sounded like the internal storage became damaged.

  2. Dalsan M
    December 21, 2013 at 6:10 pm

    Enter recovery mode and perform a factory/data reset of your phone. This should allow you to use your phone normally as it should fix the corrupt or damaged system files that are creating your issue. Note that all data and files will be erased from your phone's internal storage. There isn't a definitive way to prevent this issue as it may happen on occasion with some devices.

    With the phone off, press and hold Volume Up + Volume Down + the Power button until you see a screen that says Recovery Mode and Factory Mode. Release the buttons, and then press the Volume Up button to select Recovery Mode. Once in the Recovery Mode, use the Volume Up and Volume Down buttons to navigate the menu. Use the Menu button (bottom left button) to select the Wipe data/factory reset option. Reboot the phone, let the system initialize, and your phone should work again. More information can be found here: http://forum.xda-developers.com/showthread.php?t=2155748

    • Farhan K
      December 22, 2013 at 5:19 pm

      I tried factory mode at that time but the phone got stuck on the company logo forever overlaying the options of factory and recovery modes and when I repeated the process selecting recovery mode then after selecting recover device it showed a mount error.