How can I access a Time Capsule on my Windows 7 laptop?

marsbars06 May 8, 2012

I have a Mac and have set up a Time Capsule with backups and media. I want to be able to access this media on a Windows laptop. I have searched the Internet and can’t find a definitive way to access Time Capsule in Windows Explorer and view and edit the files. Does anyone have experience in this?


  1. Natasha
    November 10, 2012 at 10:45 pm

    I just did this. I am running Win7 managed to download and install
    After installation it automatically 'saw' my husband's time capsule and once I entered the password I was able to access and transfer files from my PC to Time Capsule & vice versa.
    Hope that helps!

    May 8, 2012 at 11:06 pm

    Hello, according to the specs in the following link, time capsule can work with PC:

    What you need to do is download the airport package for PC. This is the link:

    Also make sure that time capsule belongs to same workgroup setup in your PC

    • marsbars06
      May 9, 2012 at 6:32 am

      Thanks for your reply ;)

      I have tried that before and I did it again now. I downloaded AirPort Utility and when I am on the app I can see the Time Capsule and edit it's settings. But when the AirPort Base Station Agent pops up asking me the password, it gives me an error 67. I am putting in the right password and I don't know why it doesn't connect. So I can edit the TC settings in AirPort Utility but I can't see it in Windows Explorer :/

      • Mike
        May 9, 2012 at 5:44 pm

        The following link should cover all that is necessary to use a Time Capsule with Windows.

        Error 67 could either be duo to the security settings (see section "Hard Disk", point 3, at the above link) or the name of the time capsule is too long for Windows to process correctly.

        • marsbars06
          May 10, 2012 at 9:13 pm

          Thanks. I tried the steps in the section you specified. I did it all and I still get the same error. I don't understand what I am doing wrong :/

      • FIDELIS
        May 12, 2012 at 6:01 pm

        Hello, even if a little late, the troubleshooting steps provided next could help you out:

        Are there any spaces or dashes in the local hostname, found under the edit option of time capsule name? Try to shorten the name under 11 characters to see if it helps.

        • marsbars06
          May 12, 2012 at 10:25 pm

          There is nothing in that link about Windows but thanks ;)

          I used a name under 11 without spaces or dashes.

          I don't know what's happening. Stupid Windows!! :D

Ads by Google