Why can’t I access my MicroSD card and how can I fix it?

Daniel Porras September 24, 2012

Hello guys,

I’m having a problem with a MicroSD card. I’m using it with a USB adapter but my laptop is showing it greyed out and instead displays “Please insert a disk into removable disk”.

I tried to format it and it doesn’t work. It says it doesn’t have any memory (0KB) and also says cannot find file system… any ideas? I found an old thread by a guy who had the same issue and he found a program to solve it but the links are too old.

Does anyone has any ideas?

  1. Fala
    September 27, 2012 at 6:13 am

    try other usb port, or other computer and see whether the hdd is detected. If still not, try to go to device manager ( http://www.computerhope.com/issues/ch000833.htm ), and then assign a drive letter to the hdd. After that, try to access it from Computer, if not able to access it, format it (use quick format) and then use this program to recover your files. http://www.001-software.com/file-recovery/

  2. Dimal Chandrasiri
    September 26, 2012 at 4:53 am

    Possibility 1:
    Adapter problem can cause this kind of issu. if the connectors of the adapter doesn't connect to the memory card correctly, this will happen. try getting a new adapter and try reading it from that.

    Possibility 2:
    you might have damaged the memory card Accidently. while microSD is a very small memory device, it can be damaged due to various reasons. the people where I live tends to carry there micoSD cards with them and, sometimes they even sit while the memory card is in their back pocket. the pressure can harm the memory.

    Possibility 3:
    this is actually not a possiblity bt, a way to check the memory. insert it into a mobile device such as a phone and check whether is recognizes it. if it does, it's surely is a problem with the adapter.

    if all above fails, use your warranty to get a new memory card. kingston gives a great warranty. :)

  3. Ray
    September 25, 2012 at 1:21 am

    Sounds like the drive's partition may be missing...

    Try creating a new partition and reformatting... Hoping you did not have valuable data on there. This process will completely initialize the drive and erase prior data.

  4. Curtis C.
    September 24, 2012 at 11:14 pm

    Tried using linux to view the drive?

  5. Daniel Porras
    September 24, 2012 at 8:33 pm

    Actually I inserted the SD card in my phone and it doesn't recognize it at all, that's why I don't think that the problem is the adapter but I'll try it tonight.

    Thanks for all the answers

    • Jacqueline
      November 16, 2012 at 6:03 pm

      Did You Fix Your Sd???
      If you Did Could You Please Tell Me??


  6. Raghavendra Ksheerasagar
    September 24, 2012 at 7:17 pm

    Try format it in Nokia E siries phone.

  7. josemon maliakal
    September 24, 2012 at 1:43 pm

    The adapter may be damaged ..please try with a new one

  8. DalSan
    September 24, 2012 at 1:22 pm

    Are these the tools you were looking for? https://www.sdcard.org/downloads/formatter_3/ (SD Formatter), http://www.easeus.com/data-recovery/card-recovery-software/sd-card-recovery-freeware.htm (Easeus SD Card Recovery) and http://www.partitionwizard.com/free-partition-manager.html (Min Tool Partition Wizard)

    I would use another adapter for your card first to see if it helps first, as suggested.

  9. HLJonnalagadda
    September 24, 2012 at 12:33 pm

    Yeah best use another card reader. Must be an issue with the current one.

  10. Srinivas N
    September 24, 2012 at 10:08 am

    Try with another card reader or adapter. Sometimes it helps. Or else may be your card has gone faulty

  11. MerVzter Balacuit
    September 24, 2012 at 7:41 am

    i experienced it before, and mostly the problem is the adapter try to use another one ...

  12. bonioloff
    September 24, 2012 at 7:12 am

    Is there any guarantee ?
    Because memory is very resistant, and if it is broken, almost 100% it is physical damage, so using your guarantee is the best idea for me,,

  13. Darren Charles
    September 24, 2012 at 6:56 am

    If you're using a micro sd card, are you using it with an adaptor?

    If you are, there's a small sliding lever that allows you to access the card (when it's in the adaptor)

Ads by Google