Why can’t I access my old Maxtor external hard drive?

Wendy December 14, 2011
Whatsapp Pinterest

I’m trying to get some old backed up data on my external drive, but it doesn’t show in My Computer. It does show up when I go to “Safely Remove Hardware.” So why doesn’t it appear as a usable drive? I’ve tried the drive on three different computers and its the same for all of them. My drivers are up to date. So how do I access my files?


  1. RY
    July 10, 2012 at 6:39 am

    I'm having the same problems. I'm using a Maxtor OneTouch 4 Mini back-up from a Windows XP machine onto a Windows 7 64-bit machine. I can see the drive from Disk Management and it says it's online, but I can't access the drive directly via My Computer as no drive letter is assigned to it. I also keep getting a message that there's no NTFS partition and I don't want to format it since it's the only copy of my valuable photos/data. Help!

  2. Mike
    June 24, 2012 at 10:13 pm

    I have the same trouble and the computer tells me I have a I/O error. I don't want to erase it as I have all my music on it.

    • Bruce Epper
      June 27, 2012 at 3:45 am

      An I/O error generally indicates a problem with the communication channel, not the drive itself.

      Try it on another computer. If you get the same result, the issue is with the communication channel between the computer and the device. If it is a USB drive, the problem could be with the USB controller on the drive. Removing the drive from the enclosure and directly attaching it (via IDE/SATA) or putting it into another enclosure could remedy the issue.

  3. Cnp1958
    February 5, 2012 at 6:42 am

    Same problem here, in Disk Management I simply applied a "drive letter" to the drive and it then appeared in My Computer. In Disk Management, I "right-clicked" on the drive and selected "change drive letter and paths..." which gave me the option of assigning a drive "letter".

  4. Anonymous
    December 15, 2011 at 1:04 am

    Maybe this Microsoft fix it can help you

    also in disk management see if the hard drive is Online, if its offline turn it Online.

    • Wendand
      December 15, 2011 at 6:00 pm

      Tried it - but it didn't seem to find any problems or fix anything.

      • Anonymous
        December 15, 2011 at 6:50 pm

        well try on different version of windows, if other computers can get hold of your external hard drive then something is wrong with it or with usb cable

        you can try USBscrub
        This tiny package is designed to remove the excess registry entry that flash drives leave behind in Windows

        i tried once to clean but then if you insert again any new USB drive will add the new drivers as usual.

        DriveCleanup V0.8.1 do the same i believe

        it is up to you to decide to try them.

        • Wendand
          December 15, 2011 at 7:23 pm

          Actually NONE of my computers can see it (it DOES show up in my safely remove hardware list though).  I tried it on my desktop with Vista, laptop with Vista and netbook with XP.  Same problem on all.
          Should I still try the scrub or drivecleanup you mention?  I really think it is something missing on my external - something it has lost or gotten corrupted that used to help it mount?  when I plug it in - I can hear a sound that means my computer recognizes it - but it's not showing in MyComputer.  In Disk Management - it shows as unknown and does not have a letter.  When I right click to add a letter - it wants me to Initialized Drive - but I don't want to lose my data! 

        • Anonymous
          December 15, 2011 at 11:23 pm

          go to run and type cmd then launch it and on the black screen type DISKPART and hit enter and then TYPE: LIST DISK, see if the external hard drive is listed and its online.

          not sure if you say initialize that windows will format your hard drive

          concerning Initialize hard drive

          its up to you to decide if you want to try USBscrub.

          To initialize new disks
          In Disk Management, right-click the disk you want to initialize, and then click Initialize Disk.
          In the Initialize Disk dialog box, select the disk(s) to initialize. You can select whether to use the master boot record (MBR) or GUID partition table (GPT) partition style.
          Note The disk is initialized as a basic disk.

          External USB drive error "You must initialize the disk before Logical Disk Manager can access it"

        • Wendand
          December 16, 2011 at 12:40 am

          I followed your steps - it says it is disk7 and it's online.  Is that good?  What should I do from there?  It also says the size is 93GB but it also says free is 93GB -does that mean it's empty (it somehow erased itself?)

        • Anonymous
          December 16, 2011 at 1:07 pm

          1) Open Command Prompt.

          2) Type: diskpart.

          3) At the DISKPART prompt, type: rescan.

          concerning your question about the free space if you type this command you will get more info regarding space, file system:
          wmic volume list brief
          wmic logicaldisk list brief

          on the cmd screen navigate to your external hard drive letter, then type chkdsk and see the message

          you can also use unknown device identifier

          now try easus partition Master
          will let you know if your data are there
          The equivalent Disk Management operations would be:

          Right click on the disk in the bottom pane (click where it shows "Disk 1")
          Select "Online"
          (This brings the disk online and clears the readonly attribute making the disk read/write)
          Right click in the same place again
          Select "Initialize Disk"
          Select the "MBR (Master Boot Record)" radio button and the "OK" button
          (This creates the MBR partition layout

          Now then is up to you to decide if you would like to recover your data then you will need technicians, since you think that is ahardware problem, software do not fix hardware.

    December 14, 2011 at 11:32 pm

    Hello, have you tried checking if the drive appears in disk management?  What is your operating system?  Have you checked if drive shows in device manager?  Try the following:

    -- connect external drive
    -- right click on computer/my computer
    -- select manage
    -- enter password if needed
    -- select disk management
    -- does your drive show there?
    -- if external shows but it does not have a letter assigned to it
    -- assign a letter by right clicking on it
    -- select the change letters and paths option
    -- click on add option.
    -- select a letter available
    -- click on Ok
    I know that usually external drives are assigned a letter automatically but sometimes it does not work if there is/are problems with drive.  You loose nothing by checking with instructions above.  If there is a letter assign to it, then the problem is something else.  You could try checking if it is different by using a linux live cd.  Start up your computer from live cd and then connect your external.  If drive does not mount automatically you could mount it yourself and see if you can recover your files that way.  I like knoppix for data recovery but you could try practically any linux based live cd for doing this.http://www.knoppix.net/

    • Wendand
      December 15, 2011 at 4:11 pm

      It does not show in the top section of disk management but down below it shows as unknown.  No letter assigned.  When I right click to assign a letter it only gives me the option to "Initialize Disk".  Has it somehow erased itself?  It was initialized long ago and has data on it and used to work fine.  Should I still try the "knoppix" data recovery now - or is my problem something different?  (BTW - It DOES show in Device Manager/Disk drives with its full name - Maxtor . . . Thank you for the help!

      • Wendand
        December 15, 2011 at 6:01 pm

        If I "initialize disk" will that erase my data (like formatting a disk)?  Or should I try this?

        • FIDELIS
          December 16, 2011 at 1:19 am

          Hello, usually when you install a new drive, it will ask you to initialize.  Once disk is initialized, you can create new partitions or volumes on it.  Chances are if you initilize it, you still will not be able to see the contents on it and loose the data at same time.

          If your data is that important for you, you can use the following paid software to recover data even after partitioning/reformatting. I have had good results with this software to recover files. It is paid but it provides a trial that lets you see what it can recover. Recently, I was able to recover 390 GB of data on a drive that had been reformatted and a new operating system installed. Be aware, that it can take a long time to scan your drive, specially if it is a big drive.


          The following link is the download/buy section of the software above. The price is not to bad, considering how important your data is for you. I would get the personal license.


      • FIDELIS
        December 16, 2011 at 1:09 am

        Hello, well if it is asking for disk to be initialized, I would try checking drive with live CD(knopix).  See if you can recover you stuff from there.  If you can recover your stuff, then initialize it and assign a letter.

  6. Mike
    December 14, 2011 at 10:30 pm

    If it doesn't work on different computers it's rather a problem with your external drive than the computers and drivers.

    Maybe your external drive requires an additional power supply which you haven't properly connected.

    Is the drive actually spinning up or giving any indication as to being powered on?

    • Wendand
      December 15, 2011 at 4:25 pm

      Yep.  It has a green light on and I can hear some fan noise (?) from it.  I have checked all the power cord connections and tried different outlets and USB connectors as well.

Ads by Google