Why can I not access the internet with Windows 7 while it works fine with Windows XP?

Mike In Mexico August 12, 2010
Whatsapp Pinterest
Ads by Google

My network consists of a two wire DSL gateway/router with a Windows XP wired client and a Windows 7 wireless client, with everything working normally.

I added a wireless repeater bridge using DD-WRT installed on a Linksys router. Connecting via the bridge works perfectly using WinXP, my iPod Touch (iOS4) or a Linux client, but with my Windows 7 laptop I get “No Internet Access”. The same result whether I connect to the bridge using wireless or wired. I have also tested using a Windows Vista client, same result.

When I am connected Windows 7 bridge, I can access shares/printers on my wired client (via bridge – gateway/router), but I can’t ping the  gateway/router. IPCONFIG looks normal, with good IP, gateway, and DNS addresses. Connecting directly to the gateway/router works normally.

So, to summarize:
My bridge works fine with XP, Linux or iOS clients, but not with Windows 7 or Windows Vista. When connected to the bridge, I can’t ping the gateway/router, but I can access the rest of the network, via the same gateway/router.

If I leave the Windows 7 client connected to the bridge for about 30 minutes, it will start working normally, but it will fail again at some later time, and if I switch connections or reboot it fails immediately.

I’ve tried:
Updating drivers (even though wired and wireless have the same problem)
Safe mode
Disabled Bonjour
Fixed IP address on client
Disabling IPv6
and many other things found on web boards.

I use Windows firewall and Microsoft Security Essentials for antivirus. I’ve tried turning them both off.

Any suggestions

  1. 3hoi
    August 19, 2010 at 7:44 pm

    what's the authentication type you are using? is it WPA or WEP?

  2. Bern
    August 18, 2010 at 10:59 am

    I had a similar issue with very similar symptoms with Vista and a Westell router that was solved by updating the firmware on the router. I would check to insure that you have the latest firmware for the router and the gateway.

  3. William Brand
    August 13, 2010 at 10:47 am

    Have you tried plugging directly into your router instead of using the bridge?