Why does Windows 7 install drivers every time I boot and why is the battery icon missing from the taskbar?

Sahil December 18, 2010
Pinterest Stumbleupon Whatsapp

Every time I start my computer, three drivers start installing

1. ACPI x64-based PC
2. File as Volume Driver
3. Volume Manager

My computer is Windows 7 64-bit. I have used system restore also and done sfc / scannow also, but these drivers install each time.

Also the battery icon is missing from the taskbbar (near the clock).

Ads by Google

  1. Ace
    April 18, 2012 at 5:29 pm

    I have the same problem, but im running windows vista home premium.

  2. Anonymous
    December 22, 2010 at 10:46 am

    Hi
    Go to your device manager

    1. Click the Start button to view the Start Menu and then choose the Control Panel option.

    2. The Control Panel window opens up.

    3. The System and Security section of Control Panel opens up and you can see the direct link for the Device Manager

    4. Click on the Device Manager and window opens up.

    right click on them and uninstal; once you uninstalled reboot and let windows to install a new one, if you would like to update to newer version try driver updater soft. like drivereasy
    http://www.drivereasy.com/
    Coupon Code: DRIV-UI9E : 30% coupon, it is valid until 31/12/2010

  3. Mike
    December 21, 2010 at 11:29 pm

    To me it sounds more like a coincidence that it happened the same time Mafia 2 was installed ~ although, I may stand corrected.

    I still recommend trying the Microsoft FixIt Center since it offers quite a few system checks which might reveal a problem or two.

    You can also try doing a System Restore from Safe Mode ~ press F8 during boot to get into Safe Mode, the rest is pretty much the same. Just make sure to select a restore point before Mafia 2 installation just to be on the safe side.

  4. Mike
    December 19, 2010 at 7:00 pm

    This usually happanes if the drivers are not supported on Windows 7 64bit.
    Try downloading the right once from the manufacturers homepage and reinstall them.

    @Sahil you'll have to get the drivers for your mainboard chipset
    @Greg for your Ethernet card

    If this doesn't help give the Microsoft FixIt Center a try (http://fixitcenter.support.microsoft.com/Portal)

    • Sahil Dave
      December 20, 2010 at 8:05 pm

      i had my computer working well from months...i recently installed "mafia 2" and these prob have started occuring after that only... i did a System Restore also but no use... i dont understand.

      from that point of time, BATTERY ICON IS ALSO MISSING !!!
      The notification in the Notification Area Icons is "Show Icon and Notification" and if i change it to other options adn back to "Show Icon and Notification"...there is a pop up reading "this notification icon is not currently active"

      PLEASE HELP ME !!!

  5. Greg
    December 19, 2010 at 2:39 pm

    I have the same problem with the Ethernet driver. It installs a fresh version every time the computer boots. If the ethernet cable is disconnected, it gives an error message.

Ads by Google