Why does my laptop not connect to wired (broadband) internet connection?

Badrul Lasker May 28, 2012
Pinterest Stumbleupon Whatsapp

I have a Compaq Presario laptop, which won’t connect to any wired internet connections, but it does connect through WiFi. However, my other laptop (this one I’m using to write this) works perfectly fine with the same wired connection.

It happened earlier too, but a friend of mine did something and it worked, but this time he says he can’t do anything because it shows 0 received in the activity section under “local area connection status”. It happened all after I gave my laptop to a shop for cleaning the fan. I’m not sure if he removed something out of it. Is it possible because, it looks like some software prob to me, one more reason I’m not doubting is because it has happened before.

I see an exclamatory sign in the network icon.

I tried several things like ip config, updating the network driver, formatting the laptop and installing the new Windows 7, but nothing works.

Ads by Google

  1. Jim Chambers
    October 7, 2012 at 1:15 am

    Did you examine the ethernet port. You should see 8 wire contacts all at the same height. If one of the active contacts is bent down enough not to make contact when cable is plugged in, ethernet won't work

    • Jay
      October 12, 2012 at 5:51 am

      im having a similar problem here. my computers harddrive got corrupted a while back and i had to reinstall windows, now for some reason my computer cant even detect that i have a ethernet cable plugged and when i try to update the driver in device manager, it says cant cant update driver. i need to use a wireless connection to play world of warcraft but i cant. my device manager says that there isnt a driver installed but i dont know how to determine the type of driver that i need. plz help me.

  2. Garey Boone
    September 21, 2012 at 5:53 am

    On my laptop I have to either set it to the wireless adapter or the or the ethernet adapter through the bios itself or with the Fn (function) key on the keyboard usually another color like blue and the options for the function key might be on the front side of the key instead of the top of the key for example I have to hold down the Fn key and tap the number 2 key which has the @ symbol and the number 2 on top of the key and the wireless or ethernet toggle in blue on the front side of the number 2 key.

  3. Alex Downs
    August 31, 2012 at 2:51 am

    Oddly enough, I'm having a problem on opposite end of the spectrum, can connect to wired, and not Wifi, best guess is the proper drives have been lost or somehow removed. It might be a hardware issue since it was opened to be cleaned, a wire may have been disconnected or something?

    • mike
      September 13, 2012 at 9:41 pm

      right click icon click trouble shooting make sure ur dhcp is enabled thats what was up with mine hope this helps

  4. Dalsan
    June 23, 2012 at 5:22 pm

    I ran into this problem before, tried everything possible to no avail, and wound up having to repair install Windows and it started working. Not sure if restoring to a previous time where it was working would help you, but worth a try.

  5. Scott MacDonald
    June 6, 2012 at 3:03 pm

    I'm wondering if your saved profile of that network is corrupt. If you check out the Network and Sharing Center, and then click Manage Wireless Networks you should be able to delete and re-aquire the network. That is usually one of my first steps when a machine stops working on a network that used to be fine.

  6. Oron
    May 29, 2012 at 10:24 am

    I've only a little to add to the excellent points already made.
    Performance-wise, the important bit is to have separate channels. The greatest real speed benefit of SSD is in read performance and, by extension, for storing software. For video work, a hard disc would be good enough and there will be little speed advantage in having anything faster than that (an HDD is probably better too in tems of longevity and value for money...).
    In terms of reliability, redundant setups (i.e. most RAID configurations) are obviously a good thing, but as Mike points out, they're probably not open to you. So, if you have the money, one 256 GB SSD, a large 7,200RPM HDD and enough RAM to make sure you don't need to call on VM very often... If your budget doesn't go that far, perhaps cut to 128GB SSD, but definitely make sure to have enough RAM!

    • Sachin Kanchan
      June 6, 2012 at 6:10 am

      seems like you answered else's question in here

  7. Sachin Kanchan
    May 29, 2012 at 5:04 am

    it may be so that you have a problem with your ethernet driver,.....it is either not installed or may be you need to re-install it to see if it works....

    as Bruce advised : to check Obtain an IP address automatically’ and ‘Obtain DNS server address automatically’ are selected

    are you sure you did not have a static IP address earlier...if that is so, then you might need to consult the people who provide you the internet service ... just to be on the safe side...
    and if this is true make sure that you keep the details or make a note of the IP and DNS numbers somewhere if you may need them later

  8. jdog90000
    May 29, 2012 at 2:19 am

    A simple solution if it's not a software problem and was caused by the tech work you had done on it would just be to unscrew the back and shake it out. Look for any loose screws etc... My whole computer got messed up all because the dell guy left a screw floating around in my laptop and it kept shorting things out.

    • badrul
      May 29, 2012 at 9:20 am

      didn't find any screw.. guess I'll have to take back to the shop. :(

    May 28, 2012 at 11:27 pm

    Hello, is you ethernet adapter recognized at all in device manager? Navigate to device manager and check if there is any exclamation mark(yellow). The first thing I would have adviced would have been to check for updates for drivers but you already said you tried that.

    If after reinstalling the operating system the problem is still there, chances are there is something wrong with your ethernet adapter. I am also assuming that there is a router involved. Have you made sure to input the right password to access your network? Is there any MAC filtering involved?

    • badrul
      May 29, 2012 at 9:19 am

      thanks for the help. I've checked the device manger and don't find any (!) mark there, I've even re installed latest drivers,, nothing seems to work. About input of right password, that comes later when I'm able to connect to the internet it will redirect me to the ISP's website for that. I have no idea what MAC filtering is.

  10. Bruce Epper
    May 28, 2012 at 7:48 pm

    Right-click on the network icon in the notification area and select 'Open Network and Sharing Center'. In the resulting window, click on 'Change adapter settings'. Right-click on your your physical network adapter icon (probably labeled Local Area Connection) and select 'Properties'. In the list box, find 'Internet Protocol Version 4' and double-click on it. On the General tab, make sure that both 'Obtain an IP address automatically' and 'Obtain DNS server address automatically' are selected. Click on OK to close both dialog boxes. The settings sometimes take effect immediately and you will see the exclamation point disappear from the network icon after a couple of seconds. If this doesn't happen, right-click on your physical adapter icon again and select 'Disable' wait a few seconds for it to unplumb the adapter, right-click the icon again and select 'Enable'. After a few seconds, it should have finished replumbing the adapter and bring the connection up.

    Try to surf the web to test.

    • badrul
      May 29, 2012 at 9:27 am

      Thanks for the help Bruce, but It didn't work. It was already on "obtain an IP address automatically" I did enabling and disabling too, and it's back with (!) sign.

  11. Truefire_
    May 28, 2012 at 6:52 pm

    Sounds like you were on the right track. Since you reinstalled the OS, that's really the last software check you can do, especially since Windows 7 is good with generic wired connection drivers. It sounds like the ethernet port is shot. I'd bring it back to the shop and tell them what happened. They may be able to re-solder the connection or something.

Ads by Google