Why can I not install Talkatone on my Samsung Galaxy Ace running Android 2.3.6?

Sumble Khan May 24, 2013
Pinterest Stumbleupon Whatsapp

I wanted to ask your help in downloading the Talkatone app on my Samsung Galaxy Ace.

I’ve checked online and it says that the app is compatible with Android versions of 2.2 and up. My phone is 2.3.6 and when I go to the Google App Store to download it, a message appears on my screen saying that “This device is not compatible with this version.”

Technically, it should be. So, why won’t my phone allow the download?

Ads by Google

  1. susendeep dutta
    May 29, 2013 at 12:23 pm

    Samsung Galaxy Ace uses 800MHz MSM7227-1 Turbo processor.This is of ARMv6.

    Since this app uses requires ARMv7,hence incompatible with your phone.

  2. Artur Wrona
    May 24, 2013 at 11:39 am

    They supposedly dropped support for older ARM cores from source compiled for Play Store.

    Make sure you first enable installing apps from outside of the market
    Settings - Security - Unknown sources

    There's another version, available for download on developer's website
    http://www.talkatone.com/android-side-apk.html

    You may experience performance issues while using it.

    • Rajaa Chowdhury
      May 24, 2013 at 11:51 am

      Cool suggestion!!! :D

  3. ha14
    May 24, 2013 at 11:20 am

    What do I need to use Talkatone?
    Android: 2.2 (2.3+ is required for BlueTooth and speakerphone), armv7 or x86 CPU

    Talkatone for Android (side loading version)
    Due to inability provide quality experience on older devices we decided to exclude certain old (armv5 and armv6 based devices) from marketplace version. However, if you want to use Talkatone on older devices ON YOUR OWN RISK, you may install this version
    http://www.talkatone.com/android-side-apk.html