Why does the webcam of my laptop no longer work after upgrading from Windows Vista to Windows 7?

frank January 17, 2012
Pinterest Stumbleupon Whatsapp

I have an older Sony Vaio laptop which had Windows Vista. It now has Windows 7, but I can’t get the camera to work. What do I do?

  1. Zshan Khan Mirani
    March 29, 2012 at 9:18 am

    my sony vaio pcg-382m vgn-fz11l web cam is not working i need its drivers.

  2. Anonymous
    February 4, 2012 at 3:39 pm

    if you can't find the required driver, then try driver scanner like DriverEasy and see if it can detect the right driver
    http://drivereasy.com/

    another way is to use the driver in windows 7 with compatibility mode to windows vista.
    http://www.howtogeek.com/howto/windows-vista/using-windows-vista-compatibility-mode/

  3. FIDELIS
    January 18, 2012 at 6:32 am

    Hello, can you tell me the model of your sony laptop?  Also, did you perform an operating system upgrade from vista to windows 7? If you performed an upgrade from vista to windows 7, Was vista a 32 bit operating systeml? 

    Try the following download.  It is a big file:

    http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=11800

  4. FIDELIS
    January 18, 2012 at 4:23 am

    Hello, what version of Vista were you running? and what version of windows 7 did you upgrade to?  To find out what version you are running try the following:

    -- click on windows key + Pause/Break at same time

    Can you tell me what version it shows?

    If it is a 64 bit version of windows 7, make sure to download the drivers for 64 bits.  You probably downloaded a x86(32 bit) version.  Visit download link as before and make sure to download proper version of driver for your system.  Let me know if it works.

    • Dizbust
      January 18, 2012 at 4:50 am

      hi  I tried to find out the version by doing what you asked but I get nothing. is there any other way to find the version? also the Sony website for my model does not specify what version of driver to download all it says is that it is the original camera driver that came with the machine in 2007

      • FIDELIS
        January 18, 2012 at 4:59 am

        hello, here is another way:

        -- click on windows + E key at same time
        -- click on help tab
        -- click on about windows

        The driver you downloaded before, was it a zip folder or just and executable program?  If it is a .zip folder, unzip it and open unzipped folder.  Explore folder to see if there is an file with a .inf extension on it.  If that file is available let me know and I could direct you on how to install driver manually.

        • Dizbust
          January 18, 2012 at 5:24 am

          hey  the download was an executable program also im still having problems trying to  find what version of win 7 i have. There is no about windows when i complete the steps you told me

        • FIDELIS
          January 18, 2012 at 5:33 am

          Hello, both methods I showed you before should be there.... Try the following:

          -- click on start
          -- type winver in search box
          -- click on enter

          Or,
          -- click on start
          -- right click on Computer
          -- click on properties
          --

        • Dizbust
          January 18, 2012 at 5:42 am

          ok sorry I ave vers 6.1

        • FIDELIS
          January 18, 2012 at 5:47 am

          Hello, is it running 64 bits or 32?  Use the following to find out:

          -- click on start
          -- control panel
          -- system and security
          -- system
          -- look under system for entry system type.
          -- tell me what it says there

        • Dizbust
          January 18, 2012 at 6:14 am

          I have a 64 bit operating system

  5. FIDELIS
    January 18, 2012 at 3:31 am

    Hello, you will need to install drivers for it.  Chances are if your camera worked ok in vista, it should work in windows 7.  Visit sony website and look for camera drivers for your model.  If there is no windows 7 drivers available for your camera, you could try using vista drivers.

    • Dizbust
      January 18, 2012 at 4:08 am

      Hey  thanks for the advice ...I went to the Sony site and tried to download original drivers  when I run it says i have to run 64 bit version of DPInst.exe   i dont know what this means!  can it be fixed??

Ads by Google