Why won’t the touchpad on my Acer laptop work?
Question by barry /

The touchpad on my Acer laptop isn’t working. When I plug in a standard mouse, that does work. Is my touchpad dead?

Browse other questions & answers in the category ; tagged , , , ; or ask your own question.

Comments for this Question are closed.

If you are looking for help, please ask a new question.

We will be happy to help you!

Answers (14)
  • Julie

    Could not find the answer to your question on this page, but im having the same problem with my touch pad. it just wont budge. my cat jumped on my keyboard and ever since then its been stuck. how did you resolve the problem? i really appreciate it. thank you.

  • Fosu Fredrick

    I hope I will offered the solution to this problem.

  • None’ya

    look next to your power button and choose the button to the left with the finger and the hand and the touchpad

  • guest

    thank you!  duh.  I never saw that F7 button before.  I wonder what the rest of them do.

  • Dickyrude

    press button near top to turn on touchpad!

  • Anonymous

    remove the battery, unplug from the wall, hold the on button for 2 minutes, reinsert battery and reboot windows

  • FIDELIS

    Hello, First thing you should check, is to see if your touchpad is activated?  Most times for acer laptops you have to press following keys together:
    FN+F7

    Have you checked in device manager to see if the touchpad appears there and/or there are any problems with drivers and stuff?  Have you check if touchpad is enabled in device manager? If there is/are any problems, you will see an exclamation mark next to it and some yellow or red warning.  If you want to check, you can do the following:

    — log in with an administrator account
    — click on windows key + Pause/Break key at same time
    — click on device manager
    — scroll down to mice and other pointing devices
    — click on the + sign to expand it
    — highlight on entry and then right click
    — select properties and check under general tab for any problems.  If there is any problem it should tell you so in the box at bottom.  If there is a code, make sure to record it and then research it or post it here. 
    — on menu, click on the driver tab
    — select update drivers and if there is any, make sure to update it
    — close device manager and then restart computer
    — try to see if it works
    — if it doesn’t, follow the same steps and instead of selected update drivers, select uninstall and restart computer
    — if you are running windows 7, it will install a generic driver
    — see if it works

    Is there any software like Alps or synaptics installed?  Make sure software is up to date, if not just download the most recent version.

    • computer illiterate

      That solved my problem thank you so much!

    • FIDELIS

      Hello, I am glad your problem is solved.  If you have any more questions, you know where to come and ask them.

    • Maazy Saeed

      Hellow. Please help me. I borrowed my boyfriend’s laptop and the touch pad suddenly stopped working when I used a pen drive. It works with a mouse though. I followed your steps and when I went to properties of device manager it only shows mouse and pointing devices which disaperas if I unplug the mouse. I went to devices and printers in the control panel and It shows a computer icon with an exclamation yellow Mark and the USB mouse icon.. What should I do. Please please help.. I need to fix this for tomorrow :( and the fn+f7 button did not work. I watched videos, read articles but so far your answer has come relatively close to solving my problem. Please please help. I signed in to this forum just to fix this. Thank you.