Why did the storage capacity of my Kingston pen drive drop from 4 GB to 2 GB?

Stivinn Aura October 11, 2010
Pinterest Stumbleupon Whatsapp

DEVICE: Kingston DataTraveler 101 4 GB pen drive
(TECHNICAL NAME: DT101N/4GBIN)

PROBLEM: Pen drive memory reduced from 4 GB to 2 GB.

DETAILS: Okay, so here it goes…

I purchased a Kingston DT-101 4GB USB2.0 pen drive in Oct. 2008. It worked flawlessly for over 20 months, until recently, when I plugged it in, the usual Removable Disk J: did appear in My Computer, but only after 30-full-seconds without 0KB memory!!

I pulled out the device and reinserted it many times, hoping my pen drive would function normally, but it showed zero memory every time. Double-clicking on the J: would prompt the error: “PLEASE INSERT DISK INTO REMOVABLE DISK J:”

I could not scan/format/run the Kingston SecureTraveler (it came with the pen drive itself) to format the device/do anything with the pen drive. Also, the Disk Management (in the Computer Management) could do nothing with the device – not even change the drive letter, and it showed the device name as “USB DISK 30X” instead of the original “DT-101”. I concluded that the pen drive was fried internally.

I searched Google for the problem yesterday and suggestions like changing the disk letter from Disk Management and using HP Disk Utility flooded the internet. On one particular site, I read about “usb drive ulocker Repair_v2.9.1.1” and used it. After a few months of no usage, I finally used the pen drive yesterday – and it was still dead.

Voila! The pen drive LED started blinking as soon as I started the utility. But the application stopped responding midway in operation. Soon after, I found out that the pen drive was working, albeit with only 1.86 GB of memory! Sadly, the Device Properties still shows the pen drive named as “USB DISK 30X” and the SecureTraveler software fails to recognize the device as a Kingston DataTraveler DT-101 pen drive.

I tried another procedure that seemed to work for everyone who had the same problem as I did – it involved invoking DISKPART utility in Command Prompt (refer to the link above). It went off without a hitch, but failed to increase the drive’s capacity by even 1byte.

I’m still stuck with just 1.86GB of memory – as opposed to the full 3.7GB it’s got. Anybody who knows how to go about regaining the lost disk space may PLEASE help.

P.S. – An email sent to the Kingston support team has solicited no replies; and I doubt that going over to the small shop (from where I bought this device almost two years ago) would be of any help. The device is still in warranty, though.

System Specifications:
OS – Windows 7
CPU – Intel Dual-Core 2.0 GHz
RAM – 1 GB DDR2
MAINBOARD – nVidia 7050/nForce 610i

Ads by Google

Ads by Google