How can I solve the userinit.exe application error (0xc0000003) in Windows XP?
Question by Kyem Ghosh /

A few days ago, when I was logging on to my PC, I got an error dialogue box on the Welcome screen which stated ‘Userinit.exe application error – The application failed to initialize properly (0xc0000003). Click OK to terminate’ and my PC stopped loading except the desktop backgroud.

I searched Google for it but I got results for 0xc0000005, 0x0000022 etc. I followed the steps to solve it where it said to access the PC in safe mode, then open the task manager and to end process userinit.exe. I did but couldn’t find the ‘userinit.exe’ under the process tab.

I scanned the whole computer with my fully updated Avast, ran C-Cleaner and etc, but nothing happened. Finally I tried to repair my XP with my Windows XP CD using Command. But the interesting thing is that it couldn’t access the system32 folder where I could replace or repair the userinit.exe file.

Everything failed and I needed to format the OS and reinstall it. But still I’m struggling hard to solve and get a valid solution for this problem which I found to be a major one!

Browse other questions & answers in the category ; tagged , ; or ask your own question.

Comments for this Question are closed.

If you are looking for help, please ask a new question.

We will be happy to help you!

Answers (9)
  • Krishna Gopal Nath

    Friend. I have noticed this similar problem yesterday. I tried to restore the system in safe mode. In first attempt it was failed. But in second attempt the OS successfully restored and the problem solved in this case.

    Thanks a lot.

  • susendeep dutta

    Click on the link below to know the problem,its causes and working solution –

    • Kyem Ghosh

      I tried for system restoring using safe mode, as shown in the website, but as it couldnot access system32 folder, it couldn’t do so!!! And I’ll keep the app. provided there n I’ll use it if it happens again. But I’m still waiting for exact answers!

  • ha14

    if after format and reinstall still you have the same problem, then this can be related to hardware problem. Remove Ram and plug in again.

    userinit.exe should be the one corresponding to service pack windows xp

    Recovering userinit.exe for Windows XP

    coruuption of windows host file can also be a reason.
    how can i reset the hosts file back to default?

    also if somehow windows xp copy becamed non legitimate, then windiws will start do things like disabling desktop wall paper untill you validate the copy at microsoft.

    • Kyem Ghosh

      my pc is running good after formatting. And its not a hardware problem nor legitmate os problem. This problem was created by trojan which made userinit.exe corrupted. But after removing it by a scan, I still couldn’t access the system32 folder using command where I could replace the userinit.exe from my os disk. There might be a trick to access the system32 folder in this situation.. I’m searching for it.

    • Bruce Epper

      If your userinit.exe file is corrupt (or deleted by AV software), one way to replace it is to use a LiveCD which will completely bypass the filesystem security. You just need to make sure you are using the right version of the file based on the SP currently installed on the machine.

  • tapos

    have u tried editing the ‘registry’, take help of sm expert 4 how n what to delete 4rm ‘registry editor’. ‘regedit’ is the command to open its window via ‘run’ .

    • Kyem Ghosh

      Bhaiyya I postd it here 4 expert advise only!

    • Kyem Ghosh

      Bhaiyya I postd it here 4 som expert advise and makeuseof.Com has lots of them