Why do I have to reload MakeUseOf to see the current page?

Agro September 9, 2010
Pinterest Stumbleupon Whatsapp

I have about 50 sites that I open and peruse every day. Deal-a-day sites, webcomics, and news type sites. All of them except MakeUseOf, when they open, display the current page. Make Use Of, alone among them, displays the last home page I saw until I refresh the page. And when I go to pages 2 and 3 on a Monday, they show the last page 2 & 3 I saw the week before until I refresh the screen.

I get this on my work machine, and on my home machines, whether I look using Chrome or Firefox.

Any ideas?

  1. Aibek
    September 11, 2010 at 8:18 am

    Agro,

    The Jessaica's tip should do the trick for you. Now the reason his might be happening is because MakeUseOf uses caching to make the site faster. We tried to make sure that the cached pages are not older then an hour though.

  2. Jessica Cam W.
    September 10, 2010 at 5:01 am

    I've never had this happen to me, but you can try:"In Firefox go to > Tools > Options and select the > Advanced tab. Click the > Network subtab. Here you can clear your cache manually. Please have a look at your other "Offline Storage" settings. Is MakeUseOf.com listed as a page that has stored data for offline use? If yes, remove it. Also click the > Exceptions... button and see whether MakeUseOf.com is listed there. If yes, remove it." <--Suggestion by Tina in Why does Firefox not show latest version of MakeUseOf.com?.You might also want to check out Why do I have to clear cache to view MakeUseOf properly?

  3. Mark O'Neill
    September 9, 2010 at 6:43 pm

    This shouldn't be like this. All I can suggest is that you clear your cache and hopefully then you will see the current page.

    http://www.makeuseof.com/tag/completely-securely-delete-internet-explorer-history
    http://www.makeuseof.com/tag/configure-firefox-to-clear-your-private-data-when-shutting-down

    • Agro42
      September 9, 2010 at 7:19 pm

      It's really weird. It ONLY happens on MUO, and it happens with both Chrome and Firefox (I never use IE unless I'm hitting a Microsoft site). I usually leave the computer on and the browser open for weeks on end. It also happens after I've rebooted.