Husnain Ahmad

Who do I receive a “no root file system defined” error when trying to dual-boot Windows and Ubuntu?

16 Oct 2012
Linux-Ubuntu
Firefox 14
16 Oct 2012 | Linux-Ubuntu | Firefox 14

I am trying to install Ubuntu 12.04 using WUBI.exe from within Windows 7. All goes well but when it restarts and installation proceeds it gives and error “No root file system defined”. I have tried booting from live USB and Live CD but the same error occurs. Then i downloaded 11.10 version and booted into it using live USB but same error occurs there.

Now the thing is that I have 4 partitions on hard disk: 1- C: 147GB (with Windows 7 installed) 2- D, E which I use for file storage in Windows 3- G: 19GB NTFS formatted from Windows.

I am trying to install Ubuntu into this G drive. I want to keep my Windows 7 files and installation intact. I have tried it a while ago for 11.10 and at that time it all went super smooth. I have tried rebuilding the partition table from cmd.exe in Windows and i have also tried by formatting my G drive to ext3 using Easeus Partition manager in windows and then installing using wubi but wubi.exe didn’t detected the partition formated to ext3. When I ran the installation wizard from within Ubuntu running through live usb, i got a window with DEVICE= /dev/sda and no type no size nothing.

Here when I choose my 320GB drive it just gives the option as in picture and when i pressed install the same error “no root file system defined”. I have tried to select the new partition table option but it gives me the window to create a partition by dividing 320GB whole into whatever i want. I don’t proceed into that option because i think i will ruin my windows 7 stuff.

I am posting the pictures at of installation steps i have defined in the following link please have a look. https://www.sugarsync.com/pf/D0690308_082_7483607

https://www.sugarsync.com/pf/D0690308_082_7483603

 

Ads by Google