Why can I not see properties for my USB sticks in Windows 7 Ultimate?

Mihai Triboi August 4, 2012
Pinterest Stumbleupon Whatsapp

When I right click on any of my USB sticks plugged in, I get a “Windows Explorer has stopped working” error. I can format USB sticks from tools like USB/DVD Download Tool and LinuxLive USB Creator, but can’t even enter properties for them by right clicking on them in Windows (Windows Explorer stops working, then restarts with all explorer windows closed when I do so). I can browse their content in Windows Explorer though.

Tried doing so: Run cmd as Admin. Enter “cfs /scannow”. Result: No integrity violations.

(First I thought it’s the stick that’s broken(Transcend JetFlash 4GB), then tried another one(SanDisk Cruzer 8 GB) and got the same dead explorer.exe, guess they can’t be both broken)

Please help, I want to scan my USB sticks and format them using Windows tools. What could be the reason for this? Please guys, tell me what can I do to fix this?

Ads by Google