Why are the native monitor resolutions not detected by Ubuntu 10.10?

Dan February 13, 2011
Pinterest Stumbleupon Whatsapp

I am running a Compaq Evo D510 SFF desktop with an Intel Integrated Graphics card/controller. I have been running Linux/Ubuntu on it for almost two years now.

However, when Ubuntu 10.10 came out, there was this problem of the OS not detecting the monitors, so that I was always limited to 800×600 resolution. The native resolution of my monitor is 1024×768, which I was able to reset to in earlier Ubuntu versions after installation, and of course by default on Windows.

After I did the Ubuntu 10.10 installation, the monitor was not detected. But searching on forums and tech-sites I found this tip. Following it late one night I was finally able to fix it after some trial and error.

So after that I was on the optimum 1024×768 resolution till a few days ago when I tried a Grub customizer. After installing it, the same old problem came back. Now I have again and again tried the above tip, but somehow can’t get through.

After step 2, I click save on the gedit editor and all is fine.
When step 3 is launched in the terminal, a blank gedit editor comes up, but I don’t know what the author means by “then you need to add —-uvesafb mode_option=1366×768-24 mtrr=3 scroll=ywrap.” Is it to add this clause in the geditor or the terminal? If added in the gedit it can’t be saved with just this script in the file, there’s an error. If typed in the terminal and hit Enter, the command is not executed. Hitting enter just drops cursor to next line and just a forward arrow “>” awaits. Commands 4, 5, 6 are executable if typed and executed one by one.

I am really really confused with with the “add” in step 3, dunno know what to add where? Please help! I have been held up since last night and I am completely freaked out ! :( And, of course, I change the resolutions to my own monitor’s 1024×768, in both cases/clauses. Thanks in anticipation! I am completely exhausted trying over and over again!

I have also tried this tip but failed :(

Ads by Google

Ads by Google