Why won’t my MacBook Pro connect to Wi-Fi?
Question by DJ-VJ Eclipse /

I can’t get my wireless to connect. I receive the error “Airport Not Installed.”

Browse other questions & answers in the category , ; tagged , , , , , ; or ask your own question.

Comments for this Question are closed.

If you are looking for help, please ask a new question.

We will be happy to help you!

Answers (4)
  • Paul Fox

    Try to use free software like Netspot – it’s a simple and accessible wireless survey tool for Mac users, which allows collecting, visualizing and analyzing Wi-Fi data using any MacBook.

  • Mark

    My MBP was refusing to connect to my wifi. I tried every method i found online but none worked. I have just managed to get it working by disabling and re-enabling my firewall!! I have no idea why this worked but it has so anyone with a similar problem might want to try it.

    1. Open System Preferences > Security > Firewall
    2. Check the “Allow all incoming connections”
    3. Open browser and attempt to open a website.
    4. If step 3 works, then go back to Firewall and change to original settings (or leave “Allow all incoming connections” checked although not advised). If you choose “set access for specific services and applications” then ensure that you have included all applications you wish to allow access to the internet in the list beneath this option.

    Hope this helps!

  • Susendeep Dutta

    You can try the following –

    Hold down the power button for 10 seconds and it’ll reboot and might detect your Airport.

    Try some common troubleshooting measures to fix it mentioned in the link below –


    Similar question has also been asked and Mike has answered it –


    ” There are basically three options:
    – you deleted the AirPort connection by accident
    – your system lost track of it for whatever reason
    – your AirPort card is damaged
    First I would try to open up System Preferences, go to Network and at the top create a new Location.
    If this doesn’t help force a redetection of the hardware via Terminal.app and the command /usr/sbin/networksetup -detectnewhardware
    Your last option is to delete the file containing network hardware informations.
    delete this property list and then restart your system.
    If neither helps it is most likely and issue with the card itself. ”

    So,all in all if the above troubleshooting steps fails to fix your problem,then you need to replace the card.

  • ha14

    repair disk permission and restart.

New comment

Please login to avoid entering captcha

Log In