Why can I not install .Net Framework 2?

cheryl April 8, 2010
Pinterest Stumbleupon Whatsapp

I bought a new Acer with Windows 7. A scan pop-up says I need Framework 2. I have Framework 3.5.1, but it doesn’t show up in programs. In Windows features it’s on and off.

When I try to download version 2 it says it’s already installed.

What can I do?

Ads by Google

  1. Raj_pit031
    October 14, 2010 at 5:39 pm

    Thanks, You are Correct
    Rajesh Tiwari- 9979118178

  2. Tina
    April 9, 2010 at 5:38 am

    Cheryl,

    which program is asking for .Net Framework 2?

    Windows 7 is shipped with .Net Framework 3.5.1, which contains previous versions of .Net Framework, including 2.0. The problem you see arises if you're using tools that were released before .Net Framework 3.5.1 and thus specifically request version 2.0.

    You could try to update the software or hardware drivers.

    You can also try to cleanup .Net Framework with this tools or you could try to download and install the .Net Framework 3.5.1 SP1 from Microsoft.

    Please let us know if you need further assistance.