Can I install Mac OS X Snow Leopard on my MacBook 1.1?

Sudheer Ranga October 26, 2011
Pinterest Stumbleupon Whatsapp

I bought a MacBook 1.1 a week back. It runs Tiger but I need to install Mac OS X Snow Leopard on it. I know this MacBook doesn’t support Lion but I need to know whether I can install Snow Leopard  on it.

Ads by Google

  1. FIDELIS
    October 27, 2011 at 5:42 am

    Hello, the following are the requirements for Snow Leopard:

    http://support.apple.com/kb/SP575

    It should work ok but read all the requirements all the same.

  2. Mike
    October 27, 2011 at 1:25 am

    Yes, your MacBook will run Snow Leopard. But you probably want to upgrade the stock RAM of 512MB to at least 1GB or better 2GB (maximum supported).

    Click on the Apple logo at the top left and select "About This Mac" to find out how much RAM are currently installed.

    stock configuration is: 2x256MB 667 MHz PC2-5300 DDR2 SDRAM

    • Sudheer Ranga
      October 27, 2011 at 5:33 am

      Mine is 2GHz Intel core duo and 2 GB of ram with 250 GB of harddisk. I think this is sufficient for running snow leopard right?

      • Mike
        October 27, 2011 at 5:02 pm

        Yes it will run. We have the same MacBook running 10.6.8 with only 1.5 GB RAM