How can I install a D-link Xtreme megabit router DIR655 on Mac OS X?

Sudhir Manchanda September 14, 2011
Pinterest Stumbleupon Whatsapp

I recently bought the above router in the US, cannot install despite following the instructions. Cannot log into 192.168.1.0 as suggested. Anyone who has installed this router? Would request a solution. Thanks all.

  1. Mike
    September 14, 2011 at 10:03 pm

    Well, if you are using 192.168.1.0 it cannot work - the zero at the end indicates a network ID not a host ID.

    Most likely the address is 192.168.1.1 and for the rest of it simply follow the manual.
    The rest was already covered by Chris (reset, direct ethernet connection, ...)

    • Sudhir_manchanda
      September 15, 2011 at 4:27 am

      Thanks Mike.........I've done all that before posting my request....I
      bought it brand new in the US, now am in India...no support from
      anyplace.

      I tried logging on to 192.168.1.1 Got the mesage "A username and
      password are being requested by http://192.168.1.1. The site says:
      "WGR614v6." I tried the username and blank password, the same

      As for logging into 192.168.0.1 Get the message "A username and password
      are being requested by http://192.168.0.1. The site says: "DSL Router" 
      Tried same username blank password....same result....

      Been at it for the past one month...no help from any Mac forum....

      Wondering what next?

      Thanks anyway,

      • Mike
        September 15, 2011 at 3:50 pm

        WGR614v6 is a Netgear Wireless router with default login username: admin 
        password: password 

        As for D-Link the default login is either 
        username: admin 
        no password set 
        or 
        username: admin 
        password: admin  

        I would say the fact that you can access both 192.168.0.1 and 192.168.1.1 seems to be your actual problem. Unless you configured your network and routers that way this shouldn't be possible. 

        My first guess is that you attempt to configure the DIR655 via one connection e.g. wired while being connected to some other existing network (the WGR614) via the second network interace e.g. wireless. 

        I suggest you disconnect any wired or wireless connection before you attempt to setup the DIR655. 

  2. Chris Leonard
    September 14, 2011 at 7:15 pm

    Are you attempting to configure it for the first time over a wireless connection?  If you are plug it in directly to your Macs ethernet port. The default login is Admin and there is no password unless you bought it used and the person never reset it.  If that is the case you may need to insert a paperclip or pen tip to the reset button.

    I had this router and just sent it back for a replacement. It constantly dropped connection on me and all of a sudden the router decided that it would not speak to my modem.  All my cables were fine, when I jacked in to the modem the connection was most certainly live.  So I have no idea what happened.  Mine was purchased new.  Like I said good luck with this one.  When I am ready to spend again for a router this one is definitely going bye bye.

    I hope I was of help.  If you require further assistance, and if you just bought it call their support and they should be able to walk you through it.

    • Sudhir_manchanda
      September 15, 2011 at 4:25 am

      Thanks Chris.....I've done all that before posting my request....I bought it brand new in the US, now am in India...no support from anyplace.
      I tried logging on to 192.168.1.1 Got the mesage "A username and password are being requested by http://192.168.1.1. The site says: "WGR614v6." I tried the username and blank password, the same

      As for logging into 192.168.0.1 Get the message "A username and password are being requested by http://192.168.0.1. The site says: "DSL Router"  Tried same username blank password....same result....

      Been at it for the past one month...no help from any Mac forum....
      Wondering what next?
      Thanks anyway,
      Sudhir