How can I resolve the “package cannot be parsed” error on installing custom Flash Player in Android 2.3?

Drsunil V November 23, 2013
Pinterest Stumbleupon Whatsapp

How to resolve error of “package cannot be parsed” on installing custom flash player in Android 2.3?

  1. Hovsep A
    November 23, 2013 at 10:25 am

    the custom Flash Player do not support your android version, the apk is built with different API level than API level your phone supports. like the application will run on API level 19 but will not run below API 11, perhaps you need to change API level android:minSdkVersion
    http://developer.android.com/guide/topics/manifest/uses-sdk-element.html
    or remove API level android:minSdkVersion
    http://developer.android.com/guide/topics/manifest/uses-sdk-element.html

    • Drsunil V
      December 5, 2013 at 12:37 pm

      Thanks for relevant effort to resolve the query! I haveThumbs-uped your answer

  2. DalSan M
    November 23, 2013 at 7:51 am

    Corrupted files or incomplete files can also cause parsing errors. Try to download it again or from another source.

    • Drsunil V
      November 24, 2013 at 4:26 pm

      Thanks. How to know whether the cause is version incompatibility or corrupt file?

    • Drsunil V
      November 24, 2013 at 4:27 pm

      Thanks. How toknow whether the Thanks. How toknow whether the cause is versionincompatibility or cause is versionincompatibility or corruptfile? corruptfile?

    • DalSan M
      November 25, 2013 at 1:04 am

      Typically, an incomplete file or corrupt file will cause a "problem parsing the file", and sometimes the icon for the file would show an android icon instead of the company/program logo. Wrong version files normally, but not always, would show a "not compatible with your system" or similar error message. Again, this is not always the case, but it is what I usually notice with incomplete or corrupt files and incompatible files.

  3. Alan W
    November 23, 2013 at 7:06 am

    A common reason for that error I have read is and I quote "error could be from several causes, a common one being trying to open a package with an older android version" so check your android version against the flash player version as a starting point.

    • Drsunil V
      November 24, 2013 at 4:25 pm

      i agree with the point of version incompatibility

Ads by Google