How can I download apps to my iPhone 3G?

Michelle Kemp May 16, 2013
Pinterest Stumbleupon Whatsapp

When I choose an app for my iPhone it says download. So I go and try and download it and it says that an update is required, this app requires i0s 5!? But when I try and update anything, it says everything it is already updated.

Ads by Google

  1. Michael A
    September 11, 2013 at 4:47 am

    This free tool helps search the app store for games and apps which are compatible with older devices like the iPhone 3G and the iPod Touch 1st and 2nd generation under iOS 3.1.3 and 4.2.1:

  2. null
    May 21, 2013 at 3:45 pm

    To install or download apps to your iphone you have to get itunes and do the regulasr stuff.
    But if you think itunes is not meant for you then search google for kuaiyon ... it's in chinese but there are tutorials online .. this can get u any app .. even paid .. no jailbreak required eve.

    The other way is to get ifunbox which is another apple devices managing easy to use3 software ... get apps from internet .. search for them and install through ifunbox.

    Hope this helps!!

  3. OliviaMorgan14
    May 18, 2013 at 4:51 am

    @Michelle Kemp before downloading any app you would need to install iTunes to your mobile phone or ur MAC PC, here are some tips to choose apps according to age.

  4. ha14
    May 17, 2013 at 7:48 am

    The highest possible for the iPhone 3G is iOS 4.2.1.

    iOS 5.1 Software Update
    iPhone 4S
    iPhone 4
    iPhone 3GS
    iPad 2
    iPod touch (4th generation)
    iPod touch (3rd generation)

    You Can Now Install iOS 5 On iPhone 2G/3G And Old iPods Without Jailbreaking

  5. Rajaa Chowdhury
    May 17, 2013 at 12:02 am

    Install iTunes in your MAC or PC (free sofware) and update your iPhone firmware via it. Also you can access the iTunes store via the iTunes software too to download your apps. Double purpose served.

    • Rajaa Chowdhury
      May 17, 2013 at 12:12 am

      BTW just realised that you are using iPhone 3G for which the OS can go upto as far as iOS 4.2.1. No wonder you must already be having that version of iOS so the phone says it is up to date, however the apps are not downloading and installing as those particular apps requires minimum iOS 5 as mentioned by you. So this is the Apple trap, to constantly try to upgrade you to their latest offering. Vicious cycle Ma'am. :(

    • Rajaa Chowdhury
      May 17, 2013 at 1:20 am

      So you can only now download and install apps which are compatible upto iOS ver 4.2.1 :(

Ads by Google