Why does Google Chrome not play videos but only the audio of a video?
Question by Tyler Ferraro /

For some reason, Google Chrome won’t play videos for me. I read online that if you delete all your history, it will work, so I tried that but after one play of a video, it didn’t work anymore. The audio plays fine however. It’s just that the video won’t show.

Browse other questions & answers in the category ; tagged , , ; or ask your own question.

Comments for this Question are closed.

If you are looking for help, please ask a new question.

We will be happy to help you!

Answers (23)
  • Carol

    Finally figured it out. Check the plugins for Chrome Flash and disable. Hurray! It now works.

  • MarkfromKY

    google starts to play the first few seconds of a video and then stops I’ve done a lot of troubleshooting and cannot figure out what’s wrong, PLEASE HELP!!! I can’t get past the commercials to play the games on ADULT SWIM!!! there are other sites that don’t work either that’s just the one that upsets me….

    • Shawnb

      I have the same problem I can watch you tube videos but I cant watch Flash Player Videos ..I want my dam Porn!!

  • tommyjones

    why does google chrome play movies & videos on small screen but play in
    slowmotion on large screen

  • nancy

    Why does you tube video play on chrome but will not play on google. Google says I need latest adobe flash player but my computer won,t download it. I have adobe 11

  • eric b

    right click on the black spot then click inspect element, and then close the menu thing with a x at the top right of the menu and it should start working, idk if its supposed to do that but it worked for me

  • John Stephenson

    Does Google own Youtube? If they do why are the plugins not installed by default so that the videos can play without users having to have a degree in computing so as to get it to work?

    I mean, DUH!!!

  • Clare Dicaprio

    hey tyler! ya i came here bc i had the exact same issue,

    for awhile, “adobe flash player” pop ups have been appearing while i was online, i think what you need to do is (if you have a mac)

    -go to the spotlight icon at the top of your screen (the little magnifying glass)
    – enter adobe flash player into the search.
    -click on the top hit and “uninstall” the adobe flash player. this requires your master password so make sure you know it!

    kay hope i could help ya!

  • Crystal

    It says this question has been resolved but there’s no answer. What was the answer, because I am also having this dilemma! Thank you!

    • Tina


      There are many answers. Anonymous and ha14 suggested solutions and Ryan added to one of them. Did you see and try all these?

    • cbgbstokyo

      Actually, Fidelis’ solution–right click on a Flash video in Chrome, go to settings to disable hardware acceleration, and restart your browser–worked like a charm for me.

  • tyler ferraro

    Thanks guys! Helped a lot! :D

    • Anonymous

      thanks for the update, good luck

    • Angelsofdarknessforever

      I’ve tried all that you said and yet my video player on ANY site won’t show. I didn’t have shockwave at first and downloaded it but the videos still don’t show, what do I do?

    • ha14

      did you installed java, adobe flash…

      or try this
      1) on chrome type
      2) on the right side click on Details
      3) scroll to Flash, then deactivate the ones that comes with chrome and let only macromedia.

    • Ryan Mendenhall

      This worked!! Thanks!! Just disabled the one located at: C:\Users\**********\AppData\Local\Google\Chrome\Application\18.0.1025.168\gcswf32.dll

      And kept the one Enabled that was located here: C:\Windows\SysWOW64\Macromed\Flash\NPSWF32.dll

      MUCH appreciated!!


    • Shyla

      Worked. Thanks! I didn’t find the words macromedia. But I enabled the one that was not enabled and disenabled the other 2. Worked.

    • Confused

      I have three options (either from library, applications, or users) how do i know which to disable or not?

    • Karo

      Thanks, i just have one question since I’m rather confused at this stage, my Flash folder only has 2 files and both of them are the same:

      Name: Shockwave Flash

      Description: Shockwave Flash 11.2 r202


      Location: /Users/MyName/Library/Application Support/Google/Chrome/NPAPIFlash/Flash Player Plugin for Chrome.plugin

      Type: NPAPI

      OPTION: Disable

      MIME types:
      MIME type:
      application/x-shockwave-flash Shockwave Flash
      Description: Shockwave Flash
      File extensions: .swf
      MIME type:
      Description: FutureSplash Player
      File extensions: .spl

      Which one(s) do I disable, if any, and is there anything else I can download on my Mac to help?

      Thank you SO much!

    • ha14

      you can uninstall it then check the locations where you think you have the folders. now install again and see which folders appears, now you see which one to disable.


    Hello, what kind of video are we talking about?  If it is something like youtube, make sure your flash and java are up to date.  Also make sure to clear all the browsing history and specially cache and then restart it.  You could also try disabling hardware acceleration. 

    — go to youtube and open a video to play
    — right click on player
    — click on settings
    — uncheck hardware acceleration
    — restart your browser and try playing the video again  

Load 10 more
New comment

Please login to avoid entering captcha

Log In