How can I fix WiFi connection via AirPort on my Mac?

zulay bravo September 5, 2010
Pinterest Stumbleupon Whatsapp

I cannot connect to networks with encrypted keys, either WAP or WEP. On other non-protected networks, AirPort works fine. The AirPort card works fine, except if the WiFi has a password, and even knowing the password, it will not connect.

  1. Aibek
    September 8, 2010 at 6:58 pm

    Hey Zulay,

    Did you find any of the above tips helpful when dealing with the problem? Let us know.

    Aibek

  2. Sandy
    September 8, 2010 at 12:11 am

    Make sure your Airport Advanced Preferences is set to DHCP (Dynamic Host Configuration Protocol). This automates the assignment of IP addresses and other networking information. If you still can't connect, try renewing your DHCP lease by clicking the Renew DHCP Lease under the TCP/IP tab. If you still can't connect, ask the your systems admin if he/she has activated the MAC filtering in the wifi router. If so, request that your MAC address be included in the Permitted List of computers that can access the network.

  3. Macfan95
    September 7, 2010 at 9:56 pm

    Try going to Preferences/Network/ then make sure Airport is highlighted then click Advanced then click on the TCP/IP tab then where it says Configure IPv6 change Automatically to Off.

  4. Cesar Ponce
    September 7, 2010 at 9:55 pm

    Ok, got the facebook connection going. please link my first post to this account.

  5. Cesar Ponce
    September 7, 2010 at 9:51 pm

    I had the same problem with my router when setting the wep key to a 40-bit key OR when I selected 40-but WEP instead of 128-bit (true story). I would recommend you set your passkey to 128-bit and make it an alpha-numeric combo. This works great on my MacBook Pro running 10.6 and my Powerbook G4 running 10.5.

  6. Prante
    September 7, 2010 at 9:42 pm

    I have the same problem. I hope somebody will come up with something useful.

  7. Abelardo Gonzalez
    September 7, 2010 at 9:39 pm

    Same prob here. I gave up though. :( I have no time to troubleshoot such stuff.

Ads by Google