Why is Facebook not opening in Google Chrome?

rajeshwari October 9, 2014
Pinterest Stumbleupon Whatsapp

I’m using Google Chrome on Windows 7 and cannot load the Facebook page, but all other websites load just fine. What can I do?

  1. ha14
    October 10, 2014 at 7:25 am

    How can I reset the Hosts file back to the default?
    http://support2.microsoft.com/kb/972034/en

  2. Oron J
    October 9, 2014 at 8:13 pm

    The suggestions above should are all excellent. If they don't work, you really should try another browser (e.g. Internet Explorer). If you can get into Facebook, it'll tell you that the problem is with Chrome. If you can't get it, you'll know it's almost certainly a problem with routing (theoretically it could be a problem with your ISP or somewhere else on the internet, but that's unrealistic).

    So, if it looks like a problem with Chrome, check to see if you have any extensions, and disable them all. Test again. If you can connect, start adding the extensions back one by one, each time restarting Chrome and checking Facebook access. You will eventually find the culprit. If disabling the extensions doesn't help, try resetting Chrome (Settings, Show advanced settings..., [Reset browser settings], [Reset].

  3. Ben S
    October 9, 2014 at 3:26 pm

    Jan said it fine. Clear your cache, and then try a different browser. That will likely fix it; 99% chance.

  4. rajeshwari
    October 9, 2014 at 1:04 pm

    no i have i tryied all the options its not working....
    can i have any other option for for facebook login page... and why does it come blank page when i open face book only.....

  5. ha14
    October 9, 2014 at 11:22 am

    follow Jan F excellent suggestion.

    also try
    open cmd with administrative rights
    type: ipconfig /flushdns and hit enter
    type: exit
    see if facebook will open

  6. Jan F.
    October 9, 2014 at 10:25 am

    try clearing Chromes cache (menu > Tools > Clear browsing data, select beginning of time)
    try using incognito mode
    try using a different browser

    It's a longshot but you could also try restarting your modem/router.

    If none of that works I would assume it's an issue on your providers end (DNS, routing, blocking?).

Ads by Google