How can I download magnet links via Firefox in Ubuntu?
Question by Manu Jain /
Ads by Google

When I try to download from magnet links Firefox says “Could not launch application for the magnet links.” I am using Ubuntu 11.10. How can I fix this?



Browse other questions & answers in the category , ; tagged , , .
Join live MakeUseOf Groups on Grouvi App Join live Groups on Grouvi
Awesome Internet (and Tips)
Awesome Internet (and Tips)
1400 Members
Stay Anonymous Online
Stay Anonymous Online
1027 Members
Web Security & Privacy
Web Security & Privacy
501 Members
Linux Tips & Issues
Linux Tips & Issues
419 Members
Linux for Beginners
Linux for Beginners
360 Members

Comments for this Question are closed.

Answers (7)
  • seif mdoe

    i meet some hardness to download file meas some one ca help me?

  • lerps

    thanks so much bruce your were a big help!!!
    :)

  • Bruce Epper

    use the following command:

    sudo apt-get update && sudo apt-get install transmission

    This will update your package lists and then install the most current version of transmission (2.33).  Any version of transmission starting with 1.9 supports magnet links.

  • Abdullah Sorathia

    Type about:config into the address bar and press Enter. Next, Add a key by Right-click -> New -> Boolean -> Name: network.protocol-handler.external.magnet with value -> true
    Add another key, by Right-click -> New -> String -> Name: network.protocol-handler.app.magnet with Value ->bittorrent
    Also, do ensure that the key network.protocol-handler.expose-all is set to true.

    • manu jain

      i want to download using qbittorrent...can you help me with that...

    • Alan

      Thanks for your help.

      I am using KTorrent and found that New -> String -> Value needs to be "ktmagnetdownloader" not "ktorrent" which would have been the obvious choice.

      HTH

  • Mike

    Well, do you actually have a torrent application installed that supports magnet links? If I remember correctly the default transmission client (or version) installed with Ubuntu doesn't support them.

    You probably have to simply update your installation. I'm not much of a Ubuntu user so I can only offer the command line:

    sudo apt-get update && sudo apt-get upgrade


    How to Open Magnet Link In Browser

    Ubuntu BitTorrent (alternative clients)

Ads by Google
New comment

Please login to avoid entering captcha

Log In