Can’t Connect Epson Printer to iMac

Westozi February 2, 2010
Pinterest Stumbleupon Whatsapp

I have an Epson RX510 that will not connect to my iMac. The moment I try to print anything the whole system freezes. No amount of searching on the internet has found a solution to this problem.

I would be grateful if someone out there knows how to get round this.

Ads by Google

  1. CD Duplication
    January 25, 2011 at 6:37 pm

    Epson has recently released Mobile Printing App for Apple users, Epson’s iPrint app is a pretty sweet deal. The newest version is available as a free download in the iTunes store. With it, you can print photos from your iPhone, iPad, or iPod Touch photo albums. Right now, the wireless printing feature is supported by 18 different printers including the Epson Artisan, Stylus NX, and WorkForce models. You can get more details here http://blog.cdrom2go.com/2010/11/epson-iprint-mobile-printing-iphone-ipad-app/

    For Apple users, Epson’s iPrint app is a pretty sweet deal.

  2. CD DVD Printer
    September 15, 2010 at 6:52 am

    As far as I know I already read the answer for this question on yahoo answers or yedda (I'm not sure which among them since it's been years ago when I experienced this problem with my Mac)

    • CD Printers
      October 12, 2010 at 8:11 am

      I agree with this. You can use answer sites which are quite faster to answer your queries.

  3. seopilot
    April 19, 2010 at 9:36 am

    Thank you this nice post.

  4. ænon1mus
    February 2, 2010 at 10:43 am

    I would suggest updating your printer driver to the latest version found here: http://www.epson.com.sg/epson/drivers/driver_download.htm?mode=3&catid=4&productModel=4&catid=&pid=45&ad=1&downloadType=Macintosh

    Then try again

  5. Tina
    February 2, 2010 at 8:57 am

    Hi Westozi,

    what steps did you take to find a solution?
    Did you update the printer drivers?
    Can you test the printer on another computer or another printer on your iMac?

    • westozi
      February 3, 2010 at 8:46 am

      Thanks Tina, I searched everywhere on the net, updated drivers and then found one site where a gentleman in Geraldton said he had spent five days trying to connect his RX510 to an Imac and finally had to buy another part from Britain which cost him three pounds and he then had to wait for it to be sent to him.

Ads by Google