Can I use a printer driver designed for Mac OS X 10.9 on a 10.10 system?

MM October 28, 2014
Pinterest Stumbleupon Whatsapp

I have the newest Yosemite 10.1 Operating System on my mac, but when I download the driver for the Canon printer, it proves to be incompatible. Is it possible to use driver 10.9 for a 10.10 operating system?

  1. ha14
    November 4, 2014 at 3:29 pm

    Known Mac OS X compatible drivers from 10.0 through 10.9
    macmaps.com/printersx.html

  2. Oron J
    October 28, 2014 at 11:02 pm

    I agree with Jan. Most 10.9 printer drivers should work with 10.10.

  3. Jan F.
    October 28, 2014 at 7:07 pm

    In most cases 10.9 drivers should work just fine under 10.10. Since you appear to have tested that already you might have to wait for Canon to release drivers for the new OS X version.

    What you can try in the meantime is resetting the printing system, then re-installing the drivers and adding the printers, scanners etc. again. Especially if you performed an upgrade installation this could solve printer issues:

    open up System Preferences > Printers & Scanners
    right-click in the Printers list and select "Reset printing system"