Can I disable the “a few seconds ago” display in Facebook?

Cristián T March 9, 2014
Pinterest Stumbleupon Whatsapp

So I have this problem with Facebook in which “a few seconds ago” is displayed above every message that I send.

This used to not happen and I’m wondering if there is a way to disable that. Thanks.

  1. Rajan S
    March 13, 2014 at 6:47 am

    Hello Ben,

    I also agree with you that it is an in-built feature of Facebook.

  2. Ben S
    March 11, 2014 at 2:50 am

    I'm pretty sure this is just a feature of Facebook.
    However, you have some options.
    First, there are extensions, which are a bit of an overkill solution but may work here.
    Chat Undetected for Firefox will remove those "Seen" messages. It may also remove the time stamp.
    For Chrome, try this equivalent.
    Alternatively, if you use AdBlock Plus, you can add a custom filter to it to block these "seen" messages. Type the following into a new filter:
    /ajax/mercury/change_read_status.php$domain=facebook.com
    Hopefully one of these will help you revert Facebook's change. If not, I'd say it's unfortunately just another Facebook change we have to deal with.

    • Cristián T
      March 12, 2014 at 3:16 am

      Neither of those seemed to have fixed the problem.

    • Ben S
      March 13, 2014 at 3:27 am

      Hmm. If these tools didn't work, I'm afraid it's built into Facebook. I'm sorry that you dislike it, but you may be stuck with it.

    • Cristián T
      March 13, 2014 at 8:16 pm

      How come that hasn't happened before? How can I revert things to what it was before? This is not the first time this happened to me. The first time I had the problem, I eventually fixed it, but I don't exactly remember how I did. I know I just did something to revert it back to normal. It's really annoying and I'd like it to stop doing that every time I send a message.

    • Ben S
      March 14, 2014 at 4:40 pm

      Hmm. The only other possible fix I've seen is to make sure your computer's time is correct. Is it off at all, even by 30 seconds or so? Perhaps the time discrepancies are causing this issue.
      Have you cleared your browser cache lately? Perhaps that would clear any issue that chat is having.
      Let me know how these two go.

    • Cristián T
      March 16, 2014 at 4:20 am

      I think it actually may have to do with the time settings on my computer. Don't quote me on this, but evidence has led me to believe that my computer's CMOS battery is dying, which seems to have affected my time settings by making my time three hours slow. I first tried fixing this problem by simply changing the time, but after about an hour or so, the time would revert back to its aformentioned three hour delay. However, I recently tested Ubuntu Linux which seems to have corrected my time settings, even on Windows, interestingly enough. Speaking of Ubuntu, whenever I boot into Ubuntu instead of Windows, any browser I try (Chromium, Firefox, and Chrome) lets me send messages on Facebook without showing the "a few seconds ago" display every single time. Like I said, I don't mind Facebook putting this display in my chatboxes, but I do if it does so every time I send a message. So sometimes, just not all the time. I only like it when it's necessary, as in if I haven't sent the given recipient a message in a long time.

Ads by Google