Why does the built-in webcam of my Toshiba laptop not work?

Sino August 8, 2012
Pinterest Stumbleupon Whatsapp

I have a Toshiba L750 Satellite laptop. It has a built-in webcam that’s been working fine up until last week. Now I can’t find the program to open it.

I tried opening it via Skype, and it says “No webcam found. Connect your webcam or check it’s connect properly”. I’ve had no luck trying to use it from Facebook or YouTube, either.

I looked into the start-up menus, as well (the one that’s F2 when turning on the laptop). The webcam says that it’s still enabled. My webcam is very important to me to be able to use. Please help :(

Ads by Google

  1. kimar
    February 3, 2013 at 2:24 pm

    i have a m201 advent laptop and my built in webcam had stop working two months after i purchase. i enabled it is still did not work, can someone tell me what to do please and thanks.

    • Sino
      February 3, 2013 at 7:02 pm

      You start by asking your own question and stop leeching off of mine.

    • Jeremy
      February 14, 2013 at 7:42 pm

      Sino. did you look at my response above? I bet this is your issue. And also you don't need to be an A-hole. people are just trying to get their problem fixed like you are which seems to be the same issue.

  2. Lee Tuia
    January 25, 2013 at 8:02 am

    Hi there,

    I have a Toshiba Satellite Pro C650 Laptop and for some reason the built in webcam is not working anaymore? A message always pop's up saying "Web camera initialization failed. Please check your camera device and restart camera application or computer." I've tried everything yet I still get the same message. Does anybody know what to do? Or how to make it work again? Please? :)

    • Sino
      January 25, 2013 at 11:55 am

      Yea, it's called asking your own question and not leeching off of mine.

  3. LILI
    January 13, 2013 at 12:23 am

    i have a Toshiba Laptop windows 7 may belt in webcam from yestrday not working

  4. mikayla
    December 5, 2012 at 8:43 pm

    i tried face recongnition and my face does not appear.. just a pic of stars.. same goes for every other thing (skype, facebook, etc.) i really need help!

  5. Mahesh
    October 31, 2012 at 7:16 pm

    Reset the BIOS values to Default values.

    Check if there are yellow marks in Device manager.

    Now remove all the external devices connected to the computer including AC adapter. Now remove the battery of the computer. Now press and Hold the power button of the laptop for 2 minutes. Connect back the battery (Do not connect external devices) turn ON the computer and check if webcam is working.

  6. nicole
    October 30, 2012 at 12:37 pm

    i have a toshiba laptop and my camera is not working.. while using the skype may camera appears black and is still loading... dnt knw what's the problem.. It is really important to me... what will I do?

  7. louie
    September 25, 2012 at 12:24 am

    How do I turn on my integrated webcam? I have a toshiba laptop and I have the cyberlink youcam program. When I open the program an error message pops up that says the following: "No webcam detected. Try plugging in a webcam into your computer now. If you are using an integrated camera make sure that it is turned on." I have been searching for a way to turn it on and have not come accross it.

    • Jeremy J
      October 20, 2012 at 4:43 am

      My webcam did the same thing on my HP. I took my credit card and popped the plastic bezel that covers the screen by where the webcam is. Slightly to the right of the webcam you'll see a little white plug the is probably slightly hanging out. Push it up and bam. Your webcam works again. If you're unsure of what im talking about as far as removing the plastic bezel just youtube it. Hopefully this works for all of you guys!

    • Iamantk
      February 10, 2013 at 4:47 am

      Thank you so much. i was having the same issue and didnt want to but a new web cam and i did what you said and now it works

    • Briana
      February 14, 2013 at 8:56 am

      Thanks so much i was having the same problem the first guy was having nothing seem to work than i did what you suggested and my camera was working again, the plug had came lose

    • Jeremy J
      October 20, 2012 at 4:46 am
  8. Joel Alar
    September 10, 2012 at 10:31 am

    Did you try to check if there are a hardware switch or Fn function to enable the wifi radio of your laptop?

    • Sino
      September 10, 2012 at 12:32 pm

      Like I would care about the WiFi Radio that has nothing to do with this issue?

    • Joel Alar
      September 17, 2012 at 3:21 pm

      Sorry, I mean is the Fn function of your web cam. modern laptops has a fn function to enable the cam of your laptop.

    • Sino
      September 17, 2012 at 6:13 pm

      I knew what was meant. No help there.

  9. Tish Perez
    September 2, 2012 at 8:55 pm

    My toshiba L645 web cam us all of the sudden not working. I was wondering if I accidentally disabled it or something. Dont know where to look on my laptop for it. Help

    • Sino
      September 3, 2012 at 2:15 am

      Go ask your own question, then.

    • gordo
      September 10, 2012 at 1:04 am

      did you get this fixed?

    • Sino
      September 10, 2012 at 3:35 am

      No, the integrated webcam is still shot. Toshiba said they'd e-mail directions on sending it in, but that never went through. I just got a new plug-in webcam, so it's not really an issue.

    • Candy
      November 19, 2012 at 2:54 pm

      Hi Sino,
      Just reading through this page - I have the exact same problem!
      I've tried everything and everytime I click the webcam application it says 'web camera initialization failed. Please check your camera device and restart applicaton or computer.'
      Just wondering if you've managed to fix yours by now?!
      Its driving me crazy - it used to work!

    • Sino
      November 20, 2012 at 4:36 am

      The integrated camera could never get fixed. Computer technicians won't touch it 'cause it would void the warranty, no one knows what's wrong software wise, and the warranty doesn't even help elsewise. I got a moderately cheap plug-in camera and that works fine.

    • kris
      February 1, 2013 at 7:18 am

      we have same problem my toshiba satelite c850 have that same trouble also

  10. FIDELIS
    August 20, 2012 at 10:45 pm

    Hello, when you download the program from the toshiba site, it includes the driver. Make sure to uninstall the program, restart computer and then download the program/driver from the toshiba site. Installing it again. If that does not work, it could be a hardware issue. Have you installed any updates? or any programs that have access to webcam? Some times this can cause corruption in programs and also programs with drivers.

    • Sino
      August 21, 2012 at 2:14 pm

      This was already suggested and the link did not include the driver.

    • Bogkntan Antrei Krintea
      August 25, 2012 at 4:31 am

      Hi Sino,

      Try and run "Device doctor" found at http://www.devicedoctor.com/ or "Radar Sync" at http://www.radarsync.com/ and see whether you can find your driver.

    • Sino
      August 25, 2012 at 1:12 pm

      Neither program worked.

    • Bogkntan Antrei Krintea
      August 26, 2012 at 7:25 am

      Sino,

      Please access the following link, answer yes at the first question and follow the steps.

      http://www5.nohold.net/Toshiba/Loginr.aspx?pid=3&login=1&alt1=support&usertext=No%20webcam%20found

      Also another idea would be to try and restore your windows system to a previous point in time when the camera worked fine. You can follow the steps mentioned here: http://www.sevenforums.com/tutorials/700-system-restore.html

      If none of these solutions work i would directly call Toshiba Support at (855) 256-9005.

    • Sino
      August 26, 2012 at 1:49 pm

      Bogkntan, if you've been paying attention to any of the previous replies, I've already tried ALL of the things you've been suggesting. Two of which were in my question itself, and Toshiba not having done jack shit.

  11. pozdravcho
    August 13, 2012 at 8:09 am

    On my Toshiba L750, there's an option in the BIOS settings to either enable or disable the webcam. Check if it's not disabled in your BIOS settings - if that's not the cause, then better take it to a service station.

    • Sino
      August 13, 2012 at 2:45 pm

      Already said it was enabled in my question.

    • Sino
      August 13, 2012 at 2:45 pm

      I already said it was enabled in my question.

  12. Erlis Dhima
    August 12, 2012 at 10:10 pm

    I would recommend "ParetoLogic PC Health Advisor"... Its an app that has an option for driver scanning.. It helped me in times like this..
    Try it! Maybe it helps you too!
    Also don't forget to windows update! After all this restart your computer, and try if it works...
    Hope it helps!

  13. Christopher Harlan
    August 9, 2012 at 6:56 am

    Check your device manager and drivers. If you lack the drivers, find them online and install!

    • Sino
      August 9, 2012 at 4:09 pm

      Been trying that. Only thing I've found was the application, not the driver.

  14. Bogkntan Antrei Krintea
    August 8, 2012 at 6:50 pm

    Hi Sino,

    You could try reinstalling the webcam driver.
    You can find it here.

    http://www.drivertoshiba.com/satellite-drivers/toshiba-satellite-l750-windows-7-drivers.html

    • Sino
      August 8, 2012 at 10:05 pm

      Doesn't seem to be doing anything. ;(

    • Sino
      August 8, 2012 at 10:07 pm

      "A later version of 'TOSHIBA Web Cam Application' is already installed on this computer. Setup cannot continue.

    • Stephen
      August 8, 2012 at 10:35 pm

      Nvm about my last replies... I can find the application now, and now it says that 'Web Camera initialization failed. Please check your camera device and restart application or computer.'

    • Oron
      August 9, 2012 at 10:17 am

      It could be that your driver has become corrupt. Remove the application, and delete the driver (highlight it in Device manager and press [Del]). Now download the newest version from Toshiba and reinstall it.

    • Sino
      August 9, 2012 at 4:08 pm

      except how the driver isn't even in the Device Manager and the only thing I can get from Toshiba was the application? :/

    • Oron
      August 9, 2012 at 4:10 pm

      What about the "Webcam Driver – Download" link at the page Bogkntan Antrei Krintea suggested?

    • Sino
      August 9, 2012 at 4:13 pm

      That link only did the application, never the actual driver.

    • susendeep dutta
      August 10, 2012 at 9:17 am

      Try restoring your laptop using system restore to a state when your webcam worked.

      http://www.howtogeek.com/howto/windows-vista/using-windows-vista-system-restore/

    • Sino
      August 10, 2012 at 11:18 am

      Already tried restoring. No such luck.

  15. Bruce Epper
    August 8, 2012 at 6:45 pm

    Is the webcam listed in device manager without warning/disabled flags? Are the drivers for it present (and preferabbly up-to-date)?

    • Sino
      August 8, 2012 at 9:56 pm

      It is not listed in the device manager.

Ads by Google