Why doesn’t Boilsoft Video Splitter work with Windows 7?

Osama Javaid February 29, 2012
Pinterest Stumbleupon Whatsapp

I used to cut specific scenes from .AVI files using Boilsoft Video Splitter and Joiner in Windows XP because I don’t have to re-encode video when I use it

I’ve now installed Windows 7, and when I try to install this software, I receive the following error: “http://flic.kr/p/bz8uKe”

Please help, I really need to use this software.


Ads by Google

  1. Dav532000
    February 29, 2012 at 4:09 pm

    On there web page it states that it will run on Windows 7, you need to download the latest version from here -


    • Osama
      March 4, 2012 at 9:10 am

      already have the latest version

  2. Anonymous
    February 29, 2012 at 7:28 am

    perhaps to reinstall the soft?

    or try Machete lite free version to cut Avi?

    February 29, 2012 at 3:27 am

    Hello, you could try reinstalling the application.  Make sure to run the .exe file with  the run as administrator.  Also you could try compatibility mode

    • Osama
      March 4, 2012 at 9:10 am

      tried both

  4. Jay.0
    February 29, 2012 at 1:06 am

    Try format factory http://format-factory.en.softonic.com/download
    or any video converter.

    If you just want to join and split videos (both are freeware).

    you can also Reinsall boilsoft or use Windows live movie maker.

    • Osama
      February 29, 2012 at 3:06 pm

      I DON'T WANT Re-encoders

      • Jay.0
        February 29, 2012 at 3:58 pm

        You can maintain the same quality and codec with format factory.
        and I told you to reinstall the software.

        • Osama
          March 4, 2012 at 9:09 am

          I reinstalled too

  5. Mike
    February 29, 2012 at 1:05 am

    Have you tried updating to the "latest" version 6?

    Other then that you can only try to run it in compatibility mode. Right-click the shortcut and select properties, navigate to compatibility and try the various options.

    • Osama
      March 1, 2012 at 1:49 am

      Already using version 6..... no, the compatibility mode gives the same error too

Ads by Google